summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-functools32/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-functools32/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-functools32/PKGBUILD')
-rw-r--r--abs/core/python_modules/python2-functools32/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-functools32/PKGBUILD b/abs/core/python_modules/python2-functools32/PKGBUILD
new file mode 100644
index 0000000..b6d9078
--- /dev/null
+++ b/abs/core/python_modules/python2-functools32/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer:
+# Contributor: Stephan Conrad
+
+pkgname=python2-functools32
+_pkgver=3.2.3-2
+pkgver=${_pkgver//-/_}
+pkgrel=1
+pkgdesc="Backport of the functools module from Python 3.2.3 for use on 2.7 and PyPy"
+url="https://github.com/MiCHiLU/python-functools32"
+arch=(any)
+depends=(python2)
+makedepends=(python2-distribute)
+license=('CUSTOM')
+source=("https://pypi.python.org/packages/source/f/functools32/functools32-$_pkgver.tar.gz")
+md5sums=('09f24ffd9af9f6cd0f63cb9f4e23d4b2')
+
+build() {
+ cd functools32-$_pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd functools32-$_pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -d "$pkgdir"/usr/share/licenses/$pkgname
+ install -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/
+}
+