summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-pathlib
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-pathlib
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-pathlib')
-rw-r--r--abs/core/python_modules/python2-pathlib/PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-pathlib/PKGBUILD b/abs/core/python_modules/python2-pathlib/PKGBUILD
new file mode 100644
index 0000000..954dfb4
--- /dev/null
+++ b/abs/core/python_modules/python2-pathlib/PKGBUILD
@@ -0,0 +1,21 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: vae77 <fernandogrd@yahoo.com.br>
+
+pkgname=python2-pathlib
+pkgver=1.0.1
+pkgrel=3
+pkgdesc="This module offers a set of classes featuring all the common operations on paths in an easy, object-oriented way"
+arch=('any')
+url="http://pathlib.readthedocs.org/en/${pkgver}/"
+license=('MIT')
+depends=('python2')
+makedepends=('python2-setuptools')
+source=("http://pypi.python.org/packages/source/p/pathlib/pathlib-${pkgver}.tar.gz")
+md5sums=('5099ed48be9b1ee29b31c82819240537')
+
+package() {
+ cd "$srcdir/pathlib-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}