summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-pynzb
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-pynzb
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-pynzb')
-rw-r--r--abs/core/python_modules/python2-pynzb/PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-pynzb/PKGBUILD b/abs/core/python_modules/python2-pynzb/PKGBUILD
new file mode 100644
index 0000000..e88097b
--- /dev/null
+++ b/abs/core/python_modules/python2-pynzb/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer : vorpalblade77@gmail.com
+# Contributor : Daniel Neve <the.mephit@googlemail.com>
+pkgshort=pynzb
+pkgname=python2-$pkgshort
+pkgver=0.1.0
+pkgrel=3
+pkgdesc="A unified API for parsing NZB files"
+arch=('any')
+url="http://pypi.python.org/pypi/pynzb/"
+license=('BSD')
+depends=('python2' 'expat')
+makedepends=('python2-distribute')
+conflicts=('pynzb')
+optdepends=('python-lxml: Use lxml instead of expat')
+source=(http://pypi.python.org/packages/source/p/$pkgshort/$pkgshort-$pkgver.tar.gz
+ https://www.github.com/ericflo/$pkgshort/raw/master/LICENSE.txt)
+md5sums=('63c74a36348ac28aa99732dcb8be8c59'
+ '87d87599921bae943f981b28ecfc3cc1')
+
+build() {
+ cd $srcdir/$pkgshort-$pkgver
+ python2 setup.py build
+}
+package() {
+ cd $srcdir/$pkgshort-$pkgver
+ python2 setup.py install --root="${pkgdir}" \
+ --prefix=/usr \
+ --compile -O1
+ install -D -m644 $srcdir/LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
+}