summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules/python2-zxcvbn/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-12-09 14:34:12 (GMT)
commitf06d8e1bedfcf6d424a4736d43f366d95fb33690 (patch)
treea78baa8ac9914820a0c470c391772bcdb9e17b4d /abs/core/python_modules/python2-zxcvbn/PKGBUILD
parentada13c3f17134c5885f686509d128080450efa1b (diff)
parente4b0dec19f02e6d8e995b19a22110cac26f07ac4 (diff)
downloadlinhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.zip
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.gz
linhes_pkgbuild-f06d8e1bedfcf6d424a4736d43f366d95fb33690.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/python_modules/python2-zxcvbn/PKGBUILD')
-rw-r--r--abs/core/python_modules/python2-zxcvbn/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-zxcvbn/PKGBUILD b/abs/core/python_modules/python2-zxcvbn/PKGBUILD
new file mode 100644
index 0000000..16a6cfd
--- /dev/null
+++ b/abs/core/python_modules/python2-zxcvbn/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Cedric Girard <girard.cedric@gmail.com>
+_pythonmod=zxcvbn-python
+pkgname=python2-zxcvbn
+pkgver=4.4.14
+pkgrel=1
+pkgdesc="Password strength estimator"
+arch=('any')
+url="http://pypi.python.org/pypi/${_pythonmod}"
+license=('Apache')
+depends=(
+ 'python2'
+ )
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/${_pythonmod:0:1}/${_pythonmod}/${_pythonmod}-$pkgver.tar.gz")
+
+build() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python2 setup.py install --root=${pkgdir}
+}
+md5sums=('5c41b2ea7b7421a8f8da505bbba3bbd4')