summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 19:35:18 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 19:35:18 (GMT)
commit0304489714def760cd612f611a420386e0128298 (patch)
tree2178526ecb8a321445adf551bb7bee3618fe24df /abs/core/python_modules
parent635e14c7e0f335cc888140170f65c8d3f80021c5 (diff)
downloadlinhes_pkgbuild-0304489714def760cd612f611a420386e0128298.zip
linhes_pkgbuild-0304489714def760cd612f611a420386e0128298.tar.gz
linhes_pkgbuild-0304489714def760cd612f611a420386e0128298.tar.bz2
python-pexpect: update to 4.4.0
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-pexpect/PKGBUILD37
-rw-r--r--abs/core/python_modules/python-pexpect/__changelog1
2 files changed, 19 insertions, 19 deletions
diff --git a/abs/core/python_modules/python-pexpect/PKGBUILD b/abs/core/python_modules/python-pexpect/PKGBUILD
index 4034457..e93207c 100644
--- a/abs/core/python_modules/python-pexpect/PKGBUILD
+++ b/abs/core/python_modules/python-pexpect/PKGBUILD
@@ -1,38 +1,39 @@
# $Id$
-# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
# Contributor: Aaron Schaefer <aaron@elasticdog.com>
-pkgname=('python2-pexpect')
-pkgver=3.2
+pkgname=('python-pexpect' 'python2-pexpect')
+pkgver=4.4.0
pkgrel=1
-pkgdesc='Make Python a better tool for controlling and automating other programs'
+pkgdesc='For controlling and automating applications'
arch=('any')
-url='http://pexpect.readthedocs.org/en/latest/'
+url='https://pexpect.readthedocs.org/en/stable/'
license=('MIT')
-makedepends=('python2')
-conflicts=('python-pexpect<=2.4')
-replaces=('python-pexpect<=2.4')
-source=("http://pypi.python.org/packages/source/p/pexpect/pexpect-$pkgver.tar.gz")
-sha256sums=('dbc4c9a01c118e198d1b6ca76f31eb7292f212567f253e6b36a880e5168e961f')
+makedepends=('python' 'python2')
+source=("https://pypi.python.org/packages/fa/c3/60c0cbf96f242d0b47a82e9ca634dcd6dcb043832cf05e17540812e1c707/pexpect-$pkgver.tar.gz")
+sha256sums=('67b85a1565968e3d5b5e7c9283caddc90c3947a2625bed1905be27bd5a03e47d')
prepare() {
cp -r "pexpect-$pkgver" "python2-pexpect-$pkgver"
sed -i 's:env python:env python2:' "python2-pexpect-$pkgver/pexpect/FSM.py"
}
-#package_python-pexpect() {
-# depends+=('python')
-# cd "pexpect-$pkgver"
-# python setup.py install --root="$pkgdir"
-# install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
-#}
+package_python-pexpect() {
+ depends+=('python' 'python-ptyprocess')
+
+ cd "pexpect-$pkgver"
+ python setup.py install --root="$pkgdir"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
package_python2-pexpect() {
- depends+=('python2')
+ depends+=('python2' 'python2-ptyprocess')
+
cd "python2-pexpect-$pkgver"
python2 setup.py install --root="$pkgdir"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et:
+# getver: pypi.python.org/pypi/pexpect
diff --git a/abs/core/python_modules/python-pexpect/__changelog b/abs/core/python_modules/python-pexpect/__changelog
deleted file mode 100644
index 488d3cf..0000000
--- a/abs/core/python_modules/python-pexpect/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: rm py 3 stuff