summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-01 16:58:02 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-01 16:58:02 (GMT)
commit0c378a1d14465a6527d92ad0be44b3ef566c8eb6 (patch)
tree5516a7154f89d54b8d8f6edc4b54532fd6f742d7 /abs/core/python_modules
parentfa2d584e3f5444e0e6a198b04f4e9ecb7369d6ac (diff)
downloadlinhes_pkgbuild-0c378a1d14465a6527d92ad0be44b3ef566c8eb6.zip
linhes_pkgbuild-0c378a1d14465a6527d92ad0be44b3ef566c8eb6.tar.gz
linhes_pkgbuild-0c378a1d14465a6527d92ad0be44b3ef566c8eb6.tar.bz2
python-sphinx-alabaster-theme: dep of python-sphinx
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-sphinx-alabaster-theme/PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-sphinx-alabaster-theme/PKGBUILD b/abs/core/python_modules/python-sphinx-alabaster-theme/PKGBUILD
new file mode 100644
index 0000000..d3203be
--- /dev/null
+++ b/abs/core/python_modules/python-sphinx-alabaster-theme/PKGBUILD
@@ -0,0 +1,43 @@
+# $Id$
+# Maintainer: Johannes Löthberg <johannes@kyriasis.com>
+# Contributor: xantares
+
+pkgbase=python-sphinx-alabaster-theme
+pkgname=(python-sphinx-alabaster-theme python2-sphinx-alabaster-theme)
+pkgver=0.7.10
+pkgrel=1
+
+pkgdesc="Sphinx default theme"
+url='https://github.com/bitprophet/alabaster'
+arch=('any')
+license=('custom:BSD')
+
+makedepends=('python-setuptools' 'python2-setuptools')
+
+source=("https://pypi.org/packages/source/a/alabaster/alabaster-$pkgver.tar.gz")
+
+md5sums=('7934dccf38801faa105f6e7b4784f493')
+
+build() {
+ cp -r alabaster-"$pkgver" alabaster-"$pkgver"-py2
+
+ cd alabaster-"$pkgver"
+ python setup.py build
+
+ cd "$srcdir"/alabaster-"$pkgver"-py2
+ python2 setup.py build
+}
+
+package_python-sphinx-alabaster-theme() {
+ cd alabaster-"$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}
+
+package_python2-sphinx-alabaster-theme() {
+ cd alabaster-"$pkgver"-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}