summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-08-04 22:16:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-08-04 22:16:40 (GMT)
commit12cb37bdafb85bee1a95b27ca7bf6fe19fd6bf2a (patch)
tree91d77c41e34cb7dec37eb1de145f5f29c45fda6c /abs/core/python_modules
parent18d5b0d34e3319ff989588a36165b95d3d45683c (diff)
downloadlinhes_pkgbuild-12cb37bdafb85bee1a95b27ca7bf6fe19fd6bf2a.zip
linhes_pkgbuild-12cb37bdafb85bee1a95b27ca7bf6fe19fd6bf2a.tar.gz
linhes_pkgbuild-12cb37bdafb85bee1a95b27ca7bf6fe19fd6bf2a.tar.bz2
python-lxml: Bump to latest.
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-lxml/PKGBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/abs/core/python_modules/python-lxml/PKGBUILD b/abs/core/python_modules/python-lxml/PKGBUILD
index 606ec54..df85c69 100644
--- a/abs/core/python_modules/python-lxml/PKGBUILD
+++ b/abs/core/python_modules/python-lxml/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: $
+# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
@@ -6,8 +6,8 @@
# Contributor: Guillem Rieu <guillemr@gmx.net>
pkgname=python-lxml
-pkgver=2.2.6
-pkgrel=4
+pkgver=2.3
+pkgrel=1
pkgdesc="Python binding for the libxml2 and libxslt libraries"
arch=('i686' 'x86_64')
license=('BSD' 'GPL' 'custom')
@@ -16,19 +16,15 @@ depends=('python2' 'libxslt')
optdepends=("beautiful-soup: support for parsing not well formed HTML")
conflicts=('lxml')
replaces=('lxml')
-source=(http://codespeak.net/lxml/lxml-$pkgver.tgz)
-md5sums=('b1f700fb22d7ee9b977ee3eceb65b20c')
-
-build() {
- /bin/true
-}
+source=("http://codespeak.net/lxml/lxml-${pkgver}.tgz")
+md5sums=('a245a015fd59b63e220005f263e1682a')
package() {
cd ${srcdir}/lxml-$pkgver
- python2 setup.py install --root=${pkgdir} || return 1
+ python2 setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 LICENSES.txt ${pkgdir}/usr/share/licenses/$pkgname/LICENSE || return 1
- install -D -m644 doc/licenses/BSD.txt ${pkgdir}/usr/share/licenses/$pkgname/BSD.txt || return 1
- install -D -m644 doc/licenses/elementtree.txt ${pkgdir}/usr/share/licenses/$pkgname/elementtree.txt || return 1
+ install -D -m644 LICENSES.txt ${pkgdir}/usr/share/licenses/$pkgname/LICENSE
+ install -D -m644 doc/licenses/BSD.txt ${pkgdir}/usr/share/licenses/$pkgname/BSD.txt
+ install -D -m644 doc/licenses/elementtree.txt ${pkgdir}/usr/share/licenses/$pkgname/elementtree.txt
}