summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-26 17:13:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-26 17:13:43 (GMT)
commit2e9076c06567dd305652a7075da7eecfa7777267 (patch)
treed8ab7efd513f4f6bae5c80af74edec235a24b021 /abs/core/python_modules
parent87ab2e48e4fccf8e1dd90947cc722efdf30b74fa (diff)
downloadlinhes_pkgbuild-2e9076c06567dd305652a7075da7eecfa7777267.zip
linhes_pkgbuild-2e9076c06567dd305652a7075da7eecfa7777267.tar.gz
linhes_pkgbuild-2e9076c06567dd305652a7075da7eecfa7777267.tar.bz2
sip: update to 4.19.8
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/sip/PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/abs/core/python_modules/sip/PKGBUILD b/abs/core/python_modules/sip/PKGBUILD
new file mode 100644
index 0000000..66c8952
--- /dev/null
+++ b/abs/core/python_modules/sip/PKGBUILD
@@ -0,0 +1,66 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: riai <riai@bigfoot.com>, Ben <ben@benmazer.net>
+
+pkgbase=sip
+pkgname=('sip' 'python-sip' 'python2-sip')
+pkgver=4.19.8
+pkgrel=1
+arch=('x86_64')
+url='http://www.riverbankcomputing.com/software/sip/intro'
+license=('custom:"sip"')
+makedepends=('python' 'python2')
+source=("http://sourceforge.net/projects/pyqt/files/sip/sip-$pkgver/sip-$pkgver.tar.gz")
+sha256sums=('7eaf7a2ea7d4d38a56dd6d2506574464bddf7cf284c960801679942377c297bc')
+
+prepare() {
+ cp -a sip-$pkgver{,-py2}
+}
+
+build() {
+ cd "$srcdir"/sip-$pkgver
+ python configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ make
+
+ cd "$srcdir"/sip-$pkgver-py2
+ python2 configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ make
+}
+
+package_sip() {
+ pkgdesc="A tool that makes it easy to create Python bindings for C and C++ libraries"
+ depends=('glibc')
+
+ cd sip-$pkgver
+ make DESTDIR="$pkgdir" install -C sipgen
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python-sip() {
+ pkgdesc="Python 3.x SIP bindings for C and C++ libraries"
+ depends=('sip' 'python')
+
+ cd sip-$pkgver
+ make DESTDIR="$pkgdir" install -C siplib
+
+ install -Dm644 sipconfig.py "$pkgdir"/usr/lib/python3.6/site-packages/sipconfig.py
+ install -Dm644 sipdistutils.py "$pkgdir"/usr/lib/python3.6/site-packages/sipdistutils.py
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+
+package_python2-sip() {
+ pkgdesc="Python 2.x SIP bindings for C and C++ libraries"
+ depends=('sip' 'python2')
+
+ cd sip-$pkgver-py2
+ make DESTDIR="$pkgdir" install -C siplib
+
+ install -Dm644 sipconfig.py "$pkgdir"/usr/lib/python2.7/site-packages/sipconfig.py
+ install -Dm644 sipdistutils.py "$pkgdir"/usr/lib/python2.7/site-packages/sipdistutils.py
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}