summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2011-11-04 19:34:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2011-11-04 19:34:33 (GMT)
commit3bf0ba064b03ff390e31f0a19305ee309d70a26f (patch)
treea27a1079a3743cb1707df3d2db1d6654302131d9 /abs/core/python_modules
parent55ca795a174965deb89383cfb364fa4865664ece (diff)
downloadlinhes_pkgbuild-3bf0ba064b03ff390e31f0a19305ee309d70a26f.zip
linhes_pkgbuild-3bf0ba064b03ff390e31f0a19305ee309d70a26f.tar.gz
linhes_pkgbuild-3bf0ba064b03ff390e31f0a19305ee309d70a26f.tar.bz2
pyqt update to latest
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/pyqt/ChangeLog21
-rw-r--r--abs/core/python_modules/pyqt/PKGBUILD71
2 files changed, 53 insertions, 39 deletions
diff --git a/abs/core/python_modules/pyqt/ChangeLog b/abs/core/python_modules/pyqt/ChangeLog
deleted file mode 100644
index e20b55a..0000000
--- a/abs/core/python_modules/pyqt/ChangeLog
+++ /dev/null
@@ -1,21 +0,0 @@
-
-2009-04-11 Douglas Soares de Andrade <douglas@archlinux.org>
-
- * Fixing the rpath issue, thanks Gerardo
-
-2008-11-22 Douglas Soares de Andrade <douglas@archlinux.org>
-
- * Updated for i686: 4.4.4
-
-2008-10-22 Douglas Soares de Andrade <douglas@archlinux.org>
-
- * Rebuilt for python 2.6
-
-2008-08-09 Douglas Soares de Andrade <douglas@archlinux.org>
-
- * Updated for i686: 4.4.3
-
-2008-07-06 Douglas Soares de Andrade <douglas@archlinux.org>
-
- * Updated for i686: 4.4.2
-
diff --git a/abs/core/python_modules/pyqt/PKGBUILD b/abs/core/python_modules/pyqt/PKGBUILD
index b4083cd..8488d62 100644
--- a/abs/core/python_modules/pyqt/PKGBUILD
+++ b/abs/core/python_modules/pyqt/PKGBUILD
@@ -1,30 +1,37 @@
-# $Id: PKGBUILD 97705 2010-11-01 13:35:29Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# $Id$
+# Maintainer:
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
-pkgname=pyqt
-pkgver=4.8.1
+pkgbase=pyqt
+pkgname=('pyqt' 'python2-pyqt')
+pkgver=4.8.6
pkgrel=2
-pkgdesc="A set of Python bindings for the Qt toolkit"
arch=('i686' 'x86_64')
url="http://riverbankcomputing.co.uk/software/pyqt/intro"
license=('GPL')
-depends=('sip' 'qt' 'dbus-python')
-makedepends=('phonon' 'python-opengl' 'qt-assistant-compat')
-optdepends=('phonon: enable audio and video in PyQt applications'
- 'python-opengl: enable OpenGL 3D graphics in PyQt applications'
- 'qscintilla: QScintilla API'
- 'qt-assistant-compat: add PyQt online help in Qt Assistant')
-provides=('pyqt4')
-replaces=('pyqt4')
-conflicts=('pyqt4')
+makedepends=('qt' 'python-sip' 'dbus-python' 'python2-sip' 'phonon'
+ 'python-opengl' 'qt-assistant-compat' 'qtwebkit')
source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz")
-md5sums=('1cac8f5d715c414f9cb2751b0e84cc07')
+md5sums=('9bfd7b08b8e438b83cc50d5c58191f97')
build() {
- cd ${srcdir}/PyQt-x11-gpl-${pkgver}
+ cd "${srcdir}"
+ cp -r PyQt-x11-gpl-${pkgver} Py2Qt-x11-gpl-${pkgver}
+ cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
+ python configure.py \
+ --confirm-license \
+ --qsci-api
+
+ # Thanks Gerardo for the rpath fix
+ find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
+
+ make
+
+ ### Python2 version ###
+ cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
python2 configure.py \
--confirm-license \
-v /usr/share/sip \
@@ -36,8 +43,36 @@ build() {
make
}
-package(){
- cd ${srcdir}/PyQt-x11-gpl-${pkgver}
+package_pyqt(){
+ pkgdesc="A set of Python bindings for the Qt toolkit"
+ depends=('qtwebkit' 'python-sip')
+ optdepends=('phonon: enable audio and video in PyQt applications'
+ 'qscintilla: QScintilla API'
+ 'qt-assistant-compat: add PyQt online help in Qt Assistant')
+ replaces=('python-qt')
+ provides=('python-qt')
+
+ cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
# INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
}
+
+package_python2-pyqt(){
+ pkgdesc="PyQt: A set of Python2 bindings for the Qt toolkit"
+ depends=('pyqt' 'python2-sip' 'dbus-python')
+ optdepends=('phonon: enable audio and video in PyQt applications'
+ 'python-opengl: enable OpenGL 3D graphics in PyQt applications'
+ 'qscintilla: QScintilla API'
+ 'qt-assistant-compat: add PyQt online help in Qt Assistant')
+ replaces=('python2-qt')
+ provides=('python2-qt')
+
+ cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
+ # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
+ make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
+
+ # Provided by pyqt
+ rm ${pkgdir}/usr/bin/{pylupdate4,pyrcc4,pyuic4}
+ rm ${pkgdir}/usr/lib/qt/plugins/designer/libpythonplugin.so
+ rm ${pkgdir}/usr/share/qt/qsci/api/python/PyQt4.api
+}