summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 04:23:07 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 04:23:07 (GMT)
commit6306f7ae1895d7678eac708d86465e6e6cd8e4f0 (patch)
tree667df8705869dad25188e58ca97451e006ebbca9 /abs/core/python_modules
parent1e6a244c143a67383c507fe217f3357b398d0aa4 (diff)
downloadlinhes_pkgbuild-6306f7ae1895d7678eac708d86465e6e6cd8e4f0.zip
linhes_pkgbuild-6306f7ae1895d7678eac708d86465e6e6cd8e4f0.tar.gz
linhes_pkgbuild-6306f7ae1895d7678eac708d86465e6e6cd8e4f0.tar.bz2
python-chardet: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-chardet/PKGBUILD38
-rw-r--r--abs/core/python_modules/python-chardet/__changelog2
2 files changed, 40 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-chardet/PKGBUILD b/abs/core/python_modules/python-chardet/PKGBUILD
new file mode 100644
index 0000000..13bc9fa
--- /dev/null
+++ b/abs/core/python_modules/python-chardet/PKGBUILD
@@ -0,0 +1,38 @@
+# $Id$
+# Maintainer : Felix Yan <felixonmars@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgbase=python-chardet
+pkgname=('python2-chardet')
+pkgver=3.0.4
+pkgrel=1
+arch=('any')
+url="https://github.com/chardet/chardet"
+license=('LGPL')
+makedepends=('python2-setuptools')
+source=("https://pypi.io/packages/source/c/chardet/chardet-${pkgver}.tar.gz")
+sha512sums=('61a03b23447a2bfe52ceed4dd1b9afdb5784da1933a623776883ee9f297e341f633e27f0ce0230bd5fdc5fdb5382105ab42736a74a417ddeb9f83af57455dba5')
+
+prepare() {
+ cp -a chardet-$pkgver{,-py2}
+}
+
+package_python-chardet() {
+ depends=('python-setuptools')
+ pkgdesc="Python3 module for character encoding auto-detection"
+
+ cd chardet-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+
+package_python2-chardet() {
+ depends=('python2-setuptools')
+ pkgdesc="Python2 module for character encoding auto-detection"
+
+ cd chardet-$pkgver-py2
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # To avoid file conflict with the python3 version
+ mv "$pkgdir"/usr/bin/chardetect{,-py2}
+}
diff --git a/abs/core/python_modules/python-chardet/__changelog b/abs/core/python_modules/python-chardet/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-chardet/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+