summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-21 13:53:43 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-21 13:53:43 (GMT)
commit6704135b5e60617ba55721632b7e8276b0736959 (patch)
tree72d464d3d6f4853e1f5b16c3416dc07959d962ae /abs/core/python_modules
parentda49f66e6cf1bd0573fdbb8dee69455622b4db10 (diff)
downloadlinhes_pkgbuild-6704135b5e60617ba55721632b7e8276b0736959.zip
linhes_pkgbuild-6704135b5e60617ba55721632b7e8276b0736959.tar.gz
linhes_pkgbuild-6704135b5e60617ba55721632b7e8276b0736959.tar.bz2
pygobject: update to 3.18.2
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/pygobject/PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/abs/core/python_modules/pygobject/PKGBUILD b/abs/core/python_modules/pygobject/PKGBUILD
index 32e4c31..fc8f1c7 100644
--- a/abs/core/python_modules/pygobject/PKGBUILD
+++ b/abs/core/python_modules/pygobject/PKGBUILD
@@ -3,34 +3,33 @@
pkgbase=pygobject
pkgname=(python2-gobject pygobject-devel)
-pkgver=3.12.1
+pkgver=3.18.2
pkgrel=1
arch=(i686 x86_64)
url="https://live.gnome.org/PyGObject"
license=(LGPL)
makedepends=(python2 python2-cairo gobject-introspection gnome-common)
-source=(http://ftp.gnome.org/pub/gnome/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz)
-sha256sums=('da5fe04759e862d347b26b53a6aea0affa7cbe858b7004475fa8c7929496da35')
+source=(https://download.gnome.org/sources/$pkgbase/${pkgver:0:4}/$pkgbase-$pkgver.tar.xz)
+sha256sums=('2a3cad1517916b74e131e6002c3824361aee0671ffb0d55ded119477fc1c2c5f')
prepare() {
mkdir build-py2 build-py3 devel
cd ${pkgbase}-${pkgver}
- sed -i '/Werror=format/d' configure # gcc 4.8
}
build() {
cd build-py2
- ../${pkgbase}-${pkgver}/autogen.sh --prefix=/usr --with-python=/usr/bin/python2
+ ../${pkgbase}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python2
make
# cd ../build-py3
-# ../${pkgbase}-${pkgver}/configure --prefix=/usr
- make
+# ../${pkgbase}-${pkgver}/configure --prefix=/usr --with-python=/usr/bin/python
+# make
}
#package_python-gobject() {
# pkgdesc="Python 3 bindings for GObject"
-# depends=('gobject-introspection' 'python-cairo' "pygobject-devel=$pkgver")
+# depends=('gobject-introspection-runtime' "pygobject-devel=$pkgver" 'python' 'cairo')
# cd build-py3
# make DESTDIR="$pkgdir" install
@@ -39,15 +38,17 @@ build() {
package_python2-gobject() {
pkgdesc="Python 2 bindings for GObject"
- depends=('gobject-introspection' 'python2-cairo' "pygobject-devel=$pkgver")
+ depends=('gobject-introspection-runtime' "pygobject-devel=$pkgver" 'python2' 'cairo')
cd build-py2
make DESTDIR="$pkgdir" install
mv "$pkgdir"/usr/{include,lib/pkgconfig} "$srcdir/devel"
+ python2 -m compileall "$pkgdir"//usr/lib/python2.7/site-packages/gi
}
package_pygobject-devel() {
pkgdesc="Development files for the pygobject bindings"
+
cd "devel"
mkdir -p "$pkgdir"/usr/{include,lib}
mv include "$pkgdir/usr/"