summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 19:44:38 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 19:44:38 (GMT)
commit679fbb27905a57e4dd65fe1c5cd4231deaa6622c (patch)
tree41f8f465628187926caca9694f06052028477ac4 /abs/core/python_modules
parent9ebda64cd5c43c9e6dd8af2922831193c2ec37a1 (diff)
downloadlinhes_pkgbuild-679fbb27905a57e4dd65fe1c5cd4231deaa6622c.zip
linhes_pkgbuild-679fbb27905a57e4dd65fe1c5cd4231deaa6622c.tar.gz
linhes_pkgbuild-679fbb27905a57e4dd65fe1c5cd4231deaa6622c.tar.bz2
python-beautifulsoup4: rebuild
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/PKGBUILD16
-rw-r--r--abs/core/python_modules/python-beautifulsoup4/__changelog2
2 files changed, 8 insertions, 10 deletions
diff --git a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
index 9af6084..5ed3781 100644
--- a/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
+++ b/abs/core/python_modules/python-beautifulsoup4/PKGBUILD
@@ -4,15 +4,15 @@
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
pkgbase=python-beautifulsoup4
-pkgname=('python2-beautifulsoup4')
+pkgname=('python-beautifulsoup4' 'python2-beautifulsoup4')
pkgver=4.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python HTML/XML parser designed for quick turnaround projects like screen-scraping"
arch=('any')
url="http://www.crummy.com/software/BeautifulSoup/index.html"
license=('PSF')
-makedepends=('python2-setuptools')
-checkdepends=('python2-pytest')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest' 'python2-pytest')
source=("http://www.crummy.com/software/BeautifulSoup/bs4/download/${pkgver%.*}/${pkgbase#*-}-$pkgver.tar.gz")
sha512sums=('1a7eee4218e58cc3852e71fe4f0892f673bb46a851941264766a38eff8ef05d612d88b4641fcb478ce8f66ac50dc987ca039923c4bbb11867c74813289f7e578')
@@ -21,16 +21,16 @@ prepare() {
}
build() {
-# cd "$srcdir"/beautifulsoup4-$pkgver
-# python setup.py build
+ cd "$srcdir"/beautifulsoup4-$pkgver
+ python setup.py build
cd "$srcdir"/beautifulsoup4-$pkgver-py2
python2 setup.py build
}
check() {
-# cd "$srcdir"/beautifulsoup4-$pkgver/build
-# py.test
+ cd "$srcdir"/beautifulsoup4-$pkgver/build
+ py.test
cd "$srcdir"/beautifulsoup4-$pkgver-py2/build
py.test2
diff --git a/abs/core/python_modules/python-beautifulsoup4/__changelog b/abs/core/python_modules/python-beautifulsoup4/__changelog
deleted file mode 100644
index 4f818ef..0000000
--- a/abs/core/python_modules/python-beautifulsoup4/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-PKGBUILD: don't build py 3 stuff
-