summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 20:44:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 20:44:50 (GMT)
commit7070da83e6a9742effc1c3ac85c3e8bed8f01602 (patch)
treeca1e0197f1b646e09d1a919baa173058f91ddfce /abs/core/python_modules
parentd0ff8a96dcc88d87001dc5316890c05be04ed008 (diff)
downloadlinhes_pkgbuild-7070da83e6a9742effc1c3ac85c3e8bed8f01602.zip
linhes_pkgbuild-7070da83e6a9742effc1c3ac85c3e8bed8f01602.tar.gz
linhes_pkgbuild-7070da83e6a9742effc1c3ac85c3e8bed8f01602.tar.bz2
python-termcolor: dep of python-pytest-plugins
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-termcolor/PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-termcolor/PKGBUILD b/abs/core/python_modules/python-termcolor/PKGBUILD
new file mode 100644
index 0000000..bced757
--- /dev/null
+++ b/abs/core/python_modules/python-termcolor/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id$
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
+# Maintainer: Tim Hatch <tim@timhatch.com>
+
+pkgbase=python-termcolor
+pkgname=('python-termcolor' 'python2-termcolor')
+pkgver=1.1.0
+pkgrel=5
+pkgdesc="ANSII Color formatting for output in terminal"
+arch=('any')
+license=('GPL')
+url="http://pypi.python.org/pypi/termcolor"
+makedepends=('python' 'python2')
+source=(https://pypi.python.org/packages/source/t/termcolor/termcolor-$pkgver.tar.gz)
+sha256sums=('1d6d69ce66211143803fbc56652b41d73b4a400a2891d7bf7a1cdf4c02de613b')
+
+package_python-termcolor() {
+ depends=('python')
+
+ cd "$srcdir"/termcolor-$pkgver
+ python setup.py install --root="$pkgdir"
+}
+
+package_python2-termcolor() {
+ depends=('python2')
+
+ cd "$srcdir"/termcolor-$pkgver
+ python2 setup.py install --root="$pkgdir"
+}