summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 21:12:35 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 21:12:35 (GMT)
commit73f0d138c443e86cce8e2d32bdf214d1bf31b213 (patch)
tree411110ed5c54f10785f36179b8b4fa56561f0106 /abs/core/python_modules
parent18d8821ab00587f94b75f208b514b5863be0d370 (diff)
downloadlinhes_pkgbuild-73f0d138c443e86cce8e2d32bdf214d1bf31b213.zip
linhes_pkgbuild-73f0d138c443e86cce8e2d32bdf214d1bf31b213.tar.gz
linhes_pkgbuild-73f0d138c443e86cce8e2d32bdf214d1bf31b213.tar.bz2
python-setuptools: update to 39.0.1
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-setuptools/PKGBUILD14
1 files changed, 5 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-setuptools/PKGBUILD b/abs/core/python_modules/python-setuptools/PKGBUILD
index 2497838..c90e33c 100644
--- a/abs/core/python_modules/python-setuptools/PKGBUILD
+++ b/abs/core/python_modules/python-setuptools/PKGBUILD
@@ -4,27 +4,23 @@
pkgbase=python-setuptools
pkgname=('python-setuptools' 'python2-setuptools')
-pkgver=38.5.1
+pkgver=39.0.1
pkgrel=1
epoch=1
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages"
arch=('any')
license=('PSF')
url="http://pypi.python.org/pypi/setuptools"
-makedepends=('python-packaging' 'python2-packaging' 'python-appdirs' 'python2-appdirs' 'python-pip'
- 'python2-pip')
+makedepends=('python-packaging' 'python2-packaging' 'python-appdirs' 'python2-appdirs')
checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-pytest-flake8'
'python2-pytest-flake8' 'python-mock' 'python2-mock' 'python-pytest-fixture-config'
'python2-pytest-fixture-config' 'python-pytest-virtualenv' 'python2-pytest-virtualenv'
- 'python-wheel' 'python2-wheel' 'git')
+ 'python-wheel' 'python2-wheel' 'python-pip' 'python2-pip' 'git')
source=("$pkgbase-$pkgver.tar.gz::https://github.com/pypa/setuptools/archive/v$pkgver.tar.gz")
-sha512sums=('ab164e6de1692a64dbc468958d3150dec4ca357ea25ab4a40382af857217d576e79111c2401b03d5daf741094aa4f2e3ee535ad6d8367f66b1e83692ee9c7cf9')
+sha512sums=('34df8f10e89825975c82059c759690a2cc1486fc84c71a76875b92c2452529fbdd628e11e3043e479ea3f031af18b37a37b86d2a8d2505c300188eccdc109332')
prepare() {
- # Don't download and install deps
- sed -i '/pip.main(args)/d' setuptools-$pkgver/bootstrap.py
-
- rm -r setuptools-$pkgver/pkg_resources/_vendor
+ rm -r setuptools-$pkgver/{pkg_resources,setuptools}/_vendor
# Remove post-release tag since we are using stable tags
sed -e '/tag_build = .post/d' \