summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-01 17:22:33 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-01 17:22:33 (GMT)
commit7f8279bbc892cb8a4828333b3c850132f7d41311 (patch)
tree3ddb4c492a97ea7f24ff645bd3fda4e26fa4d289 /abs/core/python_modules
parent82f81b40efdf2d5a31239e95de67a4af51b991a5 (diff)
downloadlinhes_pkgbuild-7f8279bbc892cb8a4828333b3c850132f7d41311.zip
linhes_pkgbuild-7f8279bbc892cb8a4828333b3c850132f7d41311.tar.gz
linhes_pkgbuild-7f8279bbc892cb8a4828333b3c850132f7d41311.tar.bz2
python-idna: update to 2.6
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-idna/PKGBUILD16
-rw-r--r--abs/core/python_modules/python-idna/__changelog1
2 files changed, 8 insertions, 9 deletions
diff --git a/abs/core/python_modules/python-idna/PKGBUILD b/abs/core/python_modules/python-idna/PKGBUILD
index dd2fb8f..00a64bf 100644
--- a/abs/core/python_modules/python-idna/PKGBUILD
+++ b/abs/core/python_modules/python-idna/PKGBUILD
@@ -2,32 +2,32 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgbase=python-idna
-pkgname=('python2-idna')
-pkgver=2.5
+pkgname=('python-idna' 'python2-idna')
+pkgver=2.6
pkgrel=1
pkgdesc="Internationalized Domain Names in Applications (IDNA)"
arch=('any')
license=('BSD')
url="https://github.com/kjd/idna"
-makedepends=('python2-setuptools')
+makedepends=('python-setuptools' 'python2-setuptools')
source=("https://pypi.io/packages/source/i/idna/idna-$pkgver.tar.gz")
-md5sums=('fc1d992bef73e8824db411bb5d21f012')
+sha512sums=('cb5dbfab44c4d11521c67f9d29391f184d1267a3da6dc89f4ed12c60a7a909d5c7474c3ea2bddd0af7063f4f620e87a8dd586bb07e8b961b30b1dd7c969704c2')
prepare() {
cp -a idna-$pkgver{,-py2}
}
build() {
-# cd "$srcdir"/idna-$pkgver
-# python setup.py build
+ cd "$srcdir"/idna-$pkgver
+ python setup.py build
cd "$srcdir"/idna-$pkgver-py2
python2 setup.py build
}
check() {
-# cd "$srcdir"/idna-$pkgver
-# python setup.py test
+ cd "$srcdir"/idna-$pkgver
+ python setup.py test
cd "$srcdir"/idna-$pkgver-py2
python2 setup.py test
diff --git a/abs/core/python_modules/python-idna/__changelog b/abs/core/python_modules/python-idna/__changelog
deleted file mode 100644
index 60db758..0000000
--- a/abs/core/python_modules/python-idna/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: remove py3 stuff