summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-16 04:05:32 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-16 04:05:32 (GMT)
commita48ba24dc55c953d3b941dad26c0cc89c363c102 (patch)
tree935b89445b0d92419acddb11cf905c4fd4a8050e /abs/core/python_modules
parent6fb4f27a817519fb27927068bffcd04ee72441df (diff)
downloadlinhes_pkgbuild-a48ba24dc55c953d3b941dad26c0cc89c363c102.zip
linhes_pkgbuild-a48ba24dc55c953d3b941dad26c0cc89c363c102.tar.gz
linhes_pkgbuild-a48ba24dc55c953d3b941dad26c0cc89c363c102.tar.bz2
python-rpyc: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-rpyc/PKGBUILD30
-rw-r--r--abs/core/python_modules/python-rpyc/__changelog2
2 files changed, 32 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-rpyc/PKGBUILD b/abs/core/python_modules/python-rpyc/PKGBUILD
new file mode 100644
index 0000000..55fcea4
--- /dev/null
+++ b/abs/core/python_modules/python-rpyc/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sebastien Leduc <sebastien AT sleduc DOT fr>
+
+pkgname=('python2-rpyc')
+pkgbase='python-rpyc'
+_realname=rpyc
+pkgver=3.4.0
+pkgrel=1
+pkgdesc="Remote Python Call (RPyC), a transparent and symmetric RPC library"
+url="http://rpyc.readthedocs.org"
+arch=('any')
+license=('MIT')
+source=("https://pypi.python.org/packages/77/6d/41e01e49e75ec9a92e8637f8dc566cc01d5e6a76d4ce01f3bc54d4ff03f9/$_realname-$pkgver.tar.gz")
+md5sums=('6bba886aa3ec37f1f4cabdb56c411eba')
+
+package_python-rpyc() {
+ depends=('python' 'python-plumbum')
+ makedepends=("python-setuptools")
+ cd "$srcdir/$_realname-$pkgver"
+ python setup.py install --root="$pkgdir"/ --optimize=1
+}
+
+package_python2-rpyc() {
+ depends=('python2' 'python2-plumbum')
+ makedepends=("python2-setuptools")
+ cd "$srcdir/$_realname-$pkgver"
+ python2 setup.py install --root="$pkgdir"/ --optimize=1
+ mv "$pkgdir"/usr/bin/rpyc_classic{,2}.py
+ mv "$pkgdir"/usr/bin/rpyc_registry{,2}.py
+}
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python-rpyc/__changelog b/abs/core/python_modules/python-rpyc/__changelog
new file mode 100644
index 0000000..4f818ef
--- /dev/null
+++ b/abs/core/python_modules/python-rpyc/__changelog
@@ -0,0 +1,2 @@
+PKGBUILD: don't build py 3 stuff
+