summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-01 16:14:13 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-01 16:14:13 (GMT)
commita5d6718ab24c133d9bc220c572b71b14b498c382 (patch)
treebec1740cfc416dfa8a85bb6b6f83178450c37da0 /abs/core/python_modules
parent44a3f131989362622b19b3931dd26bead6bb1292 (diff)
downloadlinhes_pkgbuild-a5d6718ab24c133d9bc220c572b71b14b498c382.zip
linhes_pkgbuild-a5d6718ab24c133d9bc220c572b71b14b498c382.tar.gz
linhes_pkgbuild-a5d6718ab24c133d9bc220c572b71b14b498c382.tar.bz2
python-sqlalchemy: update to 1.2.4
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-sqlalchemy/PKGBUILD21
-rw-r--r--abs/core/python_modules/python-sqlalchemy/__changelog2
2 files changed, 10 insertions, 13 deletions
diff --git a/abs/core/python_modules/python-sqlalchemy/PKGBUILD b/abs/core/python_modules/python-sqlalchemy/PKGBUILD
index 33c6497..097dbeb 100644
--- a/abs/core/python_modules/python-sqlalchemy/PKGBUILD
+++ b/abs/core/python_modules/python-sqlalchemy/PKGBUILD
@@ -4,18 +4,17 @@
# Contributor: Sébastien Luttringer <seblu@aur.archlinux.org>
pkgbase=python-sqlalchemy
-pkgname=('python2-sqlalchemy')
-#pkgname=('python2-sqlalchemy')
-pkgver=1.1.11
+pkgname=('python-sqlalchemy' 'python2-sqlalchemy')
+pkgver=1.2.4
pkgrel=1
-arch=('i686' 'x86_64') # python2 package contain .so
+arch=('x86_64') # python2 package contain .so
url="http://www.sqlalchemy.org/"
license=('MIT')
-makedepends=('python2-setuptools')
-checkdepends=('python2-pytest-runner' 'python2-pytest-xdist' 'python2-mock')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python-pytest-runner' 'python2-pytest-runner' 'python-pytest-xdist' 'python2-pytest-xdist' 'python-mock' 'python2-mock')
source=("https://pypi.io/packages/source/S/SQLAlchemy/SQLAlchemy-$pkgver.tar.gz"{,.asc})
validpgpkeys=('83AF7ACE251C13E6BB7DEFBD330239C1C4DAFEE1')
-sha512sums=('322ec0baa6360099eb000ddd36e28267f64019eb72201ecf60fc478591679e0dd5d2b1139a93036d2ec0165c588ea5836a67ed21dbf7c423b64432589bd73de4'
+sha512sums=('a12d17f222cc5fc4360c439e19cae67a013af07e2c22b1f55511c4862d718578249e6bf83151eefe35957e530dbf18a565b08cded3a5e45dd21103201f4d24e8'
'SKIP')
prepare() {
@@ -23,16 +22,16 @@ prepare() {
}
build() {
-# cd "$srcdir"/SQLAlchemy-$pkgver
-# python setup.py build
+ cd "$srcdir"/SQLAlchemy-$pkgver
+ python setup.py build
cd "$srcdir"/SQLAlchemy2-$pkgver
python2 setup.py build
}
check() {
-# cd "$srcdir"/SQLAlchemy-$pkgver
-# python setup.py pytest
+ cd "$srcdir"/SQLAlchemy-$pkgver
+ python setup.py pytest
cd "$srcdir"/SQLAlchemy2-$pkgver
python2 setup.py pytest
diff --git a/abs/core/python_modules/python-sqlalchemy/__changelog b/abs/core/python_modules/python-sqlalchemy/__changelog
deleted file mode 100644
index 4f818ef..0000000
--- a/abs/core/python_modules/python-sqlalchemy/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-PKGBUILD: don't build py 3 stuff
-