summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 21:04:06 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 21:04:06 (GMT)
commitb9ca836e4df730f6ef90f8f86c6701b59ae411f9 (patch)
tree5e817706068ce2c0e1a4486e62542a5439ac24fb /abs/core/python_modules
parent9b1aa354bb83c7ee9c17efb67ae3a093bd0aafcc (diff)
downloadlinhes_pkgbuild-b9ca836e4df730f6ef90f8f86c6701b59ae411f9.zip
linhes_pkgbuild-b9ca836e4df730f6ef90f8f86c6701b59ae411f9.tar.gz
linhes_pkgbuild-b9ca836e4df730f6ef90f8f86c6701b59ae411f9.tar.bz2
python-pytest-runner: rebuild
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-pytest-runner/PKGBUILD16
-rw-r--r--abs/core/python_modules/python-pytest-runner/__changelog2
2 files changed, 8 insertions, 10 deletions
diff --git a/abs/core/python_modules/python-pytest-runner/PKGBUILD b/abs/core/python_modules/python-pytest-runner/PKGBUILD
index 5d106ce..8928aa0 100644
--- a/abs/core/python_modules/python-pytest-runner/PKGBUILD
+++ b/abs/core/python_modules/python-pytest-runner/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgbase=python-pytest-runner
-pkgname=('python2-pytest-runner')
+pkgname=('python-pytest-runner' 'python2-pytest-runner')
pkgver=2.11.1
-pkgrel=1
+pkgrel=2
pkgdesc="Invoke py.test as distutils command with dependency resolution"
arch=('any')
license=('MIT')
url="https://github.com/pytest-dev/pytest-runner"
-makedepends=('python2-pytest' 'python2-setuptools-scm' 'git')
+makedepends=('python-pytest' 'python-setuptools-scm' 'python2-pytest' 'python2-setuptools-scm' 'git')
source=("git+https://github.com/pytest-dev/pytest-runner.git#tag=$pkgver")
sha512sums=('SKIP')
@@ -18,17 +18,17 @@ prepare() {
}
build() {
-# cd "$srcdir"/pytest-runner
-# python setup.py build
+ cd "$srcdir"/pytest-runner
+ python setup.py build
cd "$srcdir"/pytest-runner-py2
python2 setup.py build
}
check() {
-# cd "$srcdir"/pytest-runner
-# python setup.py egg_info
-# PYTHONPATH="$PWD" pytest
+ cd "$srcdir"/pytest-runner
+ python setup.py egg_info
+ PYTHONPATH="$PWD" pytest
cd "$srcdir"/pytest-runner-py2
python2 setup.py egg_info
diff --git a/abs/core/python_modules/python-pytest-runner/__changelog b/abs/core/python_modules/python-pytest-runner/__changelog
deleted file mode 100644
index 4f818ef..0000000
--- a/abs/core/python_modules/python-pytest-runner/__changelog
+++ /dev/null
@@ -1,2 +0,0 @@
-PKGBUILD: don't build py 3 stuff
-