summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
committerCecil <knoppmyth@gmail.com>2011-12-09 17:18:27 (GMT)
commitc034db2c880091379f7e58c2938a9689d78fbaa9 (patch)
tree8a074205a2f3bf6ee7fb5945c53e1a1618d41973 /abs/core/python_modules
parent73b42144585c603fc64e7b1d6a126ceb7c486870 (diff)
parentb0c5755ade92ee5b76a6d56248e64254876bc931 (diff)
downloadlinhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.zip
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.gz
linhes_pkgbuild-c034db2c880091379f7e58c2938a9689d78fbaa9.tar.bz2
Merge branch 'testing' of ssh://cesman@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python2-distribute/PKGBUILD24
-rw-r--r--abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch51
-rw-r--r--abs/core/python_modules/python_aosd/PKGBUILD16
3 files changed, 91 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-distribute/PKGBUILD b/abs/core/python_modules/python2-distribute/PKGBUILD
new file mode 100644
index 0000000..04c0f48
--- /dev/null
+++ b/abs/core/python_modules/python2-distribute/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sebastien Binet <binet@farnsworth>
+pkgname=python2-distribute
+pkgver=0.6.14
+pkgrel=4
+pkgdesc="A collection of extensions to the Python 2 distutils"
+arch=('any')
+license=('PSF')
+url="http://packages.python.org/distribute"
+depends=('python2')
+conflicts=('setuptools')
+replaces=('setuptools')
+provides=('setuptools=0.6c11')
+source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
+ distribute-${pkgver}_python2_and_3.patch)
+
+package() {
+ cd ${srcdir}/distribute-${pkgver}
+ patch -Np1 -i ../distribute-${pkgver}_python2_and_3.patch
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
+md5sums=('83ada58a83d99b28c806703597323b80'
+ 'bbf5554ade06f27285f81ed8a8a3a3f8')
diff --git a/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch b/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
new file mode 100644
index 0000000..dc5da86
--- /dev/null
+++ b/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
@@ -0,0 +1,51 @@
+diff -Naur distribute-0.6.14.ori//distribute.egg-info/entry_points.txt distribute-0.6.14/distribute.egg-info/entry_points.txt
+--- distribute-0.6.14.ori//distribute.egg-info/entry_points.txt 2010-07-14 20:14:10.000000000 -0400
++++ distribute-0.6.14/distribute.egg-info/entry_points.txt 2010-10-21 09:26:43.386667396 -0400
+@@ -31,7 +31,8 @@
+ depends.txt = setuptools.command.egg_info:warn_depends_obsolete
+
+ [console_scripts]
+-easy_install = setuptools.command.easy_install:main
++easy_install-3.1 = setuptools.command.easy_install:main
++easy_install-2.7 = setuptools.command.easy_install:main
+ easy_install-2.6 = setuptools.command.easy_install:main
+
+ [setuptools.file_finders]
+diff -Naur distribute-0.6.14.ori//distribute_setup.py distribute-0.6.14/distribute_setup.py
+--- distribute-0.6.14.ori//distribute_setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/distribute_setup.py 2010-10-21 09:25:18.356667404 -0400
+@@ -299,8 +299,7 @@
+ log.warn('Could not find the install location')
+ return
+ pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
+- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
+- (SETUPTOOLS_FAKED_VERSION, pyver)
++ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
+ pkg_info = os.path.join(placeholder, setuptools_file)
+ if os.path.exists(pkg_info):
+ log.warn('%s already exists', pkg_info)
+diff -Naur distribute-0.6.14.ori//setup.py distribute-0.6.14/setup.py
+--- distribute-0.6.14.ori//setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/setup.py 2010-10-21 09:32:44.850000736 -0400
+@@ -96,6 +96,8 @@
+ f.close()
+
+
++console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
++
+ # if we are installing Distribute using "python setup.py install"
+ # we need to get setuptools out of the way
+ def _easy_install_marker():
+@@ -182,11 +184,7 @@
+ "dependency_links.txt = setuptools.command.egg_info:overwrite_arg",
+ ],
+
+- "console_scripts": [
+- "easy_install = setuptools.command.easy_install:main",
+- "easy_install-%s = setuptools.command.easy_install:main"
+- % sys.version[:3]
+- ],
++ "console_scripts": console_scripts,
+
+ "setuptools.file_finders":
+ ["svn_cvs = setuptools.command.sdist:_default_revctrl"],
diff --git a/abs/core/python_modules/python_aosd/PKGBUILD b/abs/core/python_modules/python_aosd/PKGBUILD
new file mode 100644
index 0000000..35af3d7
--- /dev/null
+++ b/abs/core/python_modules/python_aosd/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=python_aosd
+pkgver=0.2.2
+pkgrel=1
+pkgdesc="Python binding for libaosd_ an on screen display (OSD) library"
+arch=(any)
+url="http://code.google.com/p/python-aosd/"
+license=('GPL')
+depends=('python2' 'cython2' 'libaosd' 'pyrex' 'pycairo')
+source=(http://python-aosd.googlecode.com/files/python-aosd-${pkgver}.tar.gz)
+
+build() {
+ cd "${srcdir}/python-aosd-${pkgver}"
+ python2 setup.py install --root="${pkgdir}" --prefix=/usr || return 1
+}
+
+md5sums=('45c757fe4c171a0b778c7e73d3839ef5')