summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-12-07 19:42:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-12-07 19:42:21 (GMT)
commitd110649b4180587f1e4064684ba9c61df83a6ec1 (patch)
treea037e4c885c34ec427fbb4db3cb25b8dce410e50 /abs/core/python_modules
parent1bce17620017466501293fb28b22d2920aa34924 (diff)
downloadlinhes_pkgbuild-d110649b4180587f1e4064684ba9c61df83a6ec1.zip
linhes_pkgbuild-d110649b4180587f1e4064684ba9c61df83a6ec1.tar.gz
linhes_pkgbuild-d110649b4180587f1e4064684ba9c61df83a6ec1.tar.bz2
python2-distribute: needed by cython
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python2-distribute/PKGBUILD24
-rw-r--r--abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch51
2 files changed, 75 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-distribute/PKGBUILD b/abs/core/python_modules/python2-distribute/PKGBUILD
new file mode 100644
index 0000000..04c0f48
--- /dev/null
+++ b/abs/core/python_modules/python2-distribute/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Stéphane Gaudreault <stephane@archlinux.org>
+# Contributor: Sebastien Binet <binet@farnsworth>
+pkgname=python2-distribute
+pkgver=0.6.14
+pkgrel=4
+pkgdesc="A collection of extensions to the Python 2 distutils"
+arch=('any')
+license=('PSF')
+url="http://packages.python.org/distribute"
+depends=('python2')
+conflicts=('setuptools')
+replaces=('setuptools')
+provides=('setuptools=0.6c11')
+source=(http://pypi.python.org/packages/source/d/distribute/distribute-${pkgver}.tar.gz
+ distribute-${pkgver}_python2_and_3.patch)
+
+package() {
+ cd ${srcdir}/distribute-${pkgver}
+ patch -Np1 -i ../distribute-${pkgver}_python2_and_3.patch
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+}
+# vim: set noexpandtab tabstop=8 shiftwidth=8 textwidth=132 autoindent
+md5sums=('83ada58a83d99b28c806703597323b80'
+ 'bbf5554ade06f27285f81ed8a8a3a3f8')
diff --git a/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch b/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
new file mode 100644
index 0000000..dc5da86
--- /dev/null
+++ b/abs/core/python_modules/python2-distribute/distribute-0.6.14_python2_and_3.patch
@@ -0,0 +1,51 @@
+diff -Naur distribute-0.6.14.ori//distribute.egg-info/entry_points.txt distribute-0.6.14/distribute.egg-info/entry_points.txt
+--- distribute-0.6.14.ori//distribute.egg-info/entry_points.txt 2010-07-14 20:14:10.000000000 -0400
++++ distribute-0.6.14/distribute.egg-info/entry_points.txt 2010-10-21 09:26:43.386667396 -0400
+@@ -31,7 +31,8 @@
+ depends.txt = setuptools.command.egg_info:warn_depends_obsolete
+
+ [console_scripts]
+-easy_install = setuptools.command.easy_install:main
++easy_install-3.1 = setuptools.command.easy_install:main
++easy_install-2.7 = setuptools.command.easy_install:main
+ easy_install-2.6 = setuptools.command.easy_install:main
+
+ [setuptools.file_finders]
+diff -Naur distribute-0.6.14.ori//distribute_setup.py distribute-0.6.14/distribute_setup.py
+--- distribute-0.6.14.ori//distribute_setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/distribute_setup.py 2010-10-21 09:25:18.356667404 -0400
+@@ -299,8 +299,7 @@
+ log.warn('Could not find the install location')
+ return
+ pyver = '%s.%s' % (sys.version_info[0], sys.version_info[1])
+- setuptools_file = 'setuptools-%s-py%s.egg-info' % \
+- (SETUPTOOLS_FAKED_VERSION, pyver)
++ setuptools_file = 'setuptools-%s.egg-info' % SETUPTOOLS_FAKED_VERSION
+ pkg_info = os.path.join(placeholder, setuptools_file)
+ if os.path.exists(pkg_info):
+ log.warn('%s already exists', pkg_info)
+diff -Naur distribute-0.6.14.ori//setup.py distribute-0.6.14/setup.py
+--- distribute-0.6.14.ori//setup.py 2010-07-14 19:53:38.000000000 -0400
++++ distribute-0.6.14/setup.py 2010-10-21 09:32:44.850000736 -0400
+@@ -96,6 +96,8 @@
+ f.close()
+
+
++console_scripts = ["easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3]]
++
+ # if we are installing Distribute using "python setup.py install"
+ # we need to get setuptools out of the way
+ def _easy_install_marker():
+@@ -182,11 +184,7 @@
+ "dependency_links.txt = setuptools.command.egg_info:overwrite_arg",
+ ],
+
+- "console_scripts": [
+- "easy_install = setuptools.command.easy_install:main",
+- "easy_install-%s = setuptools.command.easy_install:main"
+- % sys.version[:3]
+- ],
++ "console_scripts": console_scripts,
+
+ "setuptools.file_finders":
+ ["svn_cvs = setuptools.command.sdist:_default_revctrl"],