summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-04-11 20:00:37 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-04-11 20:00:37 (GMT)
commitd28345e2dcb4b1d910dc3a91421c791b00967a4e (patch)
tree9e709ce3116f493211214145363c65fe0cce530d /abs/core/python_modules
parent113ce21c188ca93066e66d410d22a73fa7313d03 (diff)
downloadlinhes_pkgbuild-d28345e2dcb4b1d910dc3a91421c791b00967a4e.zip
linhes_pkgbuild-d28345e2dcb4b1d910dc3a91421c791b00967a4e.tar.gz
linhes_pkgbuild-d28345e2dcb4b1d910dc3a91421c791b00967a4e.tar.bz2
python-werkzeug: update to 0.14.1-2
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-werkzeug/PKGBUILD39
-rw-r--r--abs/core/python_modules/python-werkzeug/__changelog1
2 files changed, 18 insertions, 22 deletions
diff --git a/abs/core/python_modules/python-werkzeug/PKGBUILD b/abs/core/python_modules/python-werkzeug/PKGBUILD
index b8bfd64..0970226 100644
--- a/abs/core/python_modules/python-werkzeug/PKGBUILD
+++ b/abs/core/python_modules/python-werkzeug/PKGBUILD
@@ -5,57 +5,54 @@
# Contributor: Dan Serban
# Contributor: Richard Murri
-pkgname=('python2-werkzeug')
-pkgver=0.12.2
-pkgrel=1
+pkgname=('python-werkzeug' 'python2-werkzeug')
+pkgver=0.14.1
+pkgrel=2
pkgdesc='Swiss Army knife of Python web development'
url='http://werkzeug.pocoo.org/'
arch=('any')
license=('custom:BSD')
-makedepends=('python2-setuptools' 'python2-pytest' 'python2-requests')
+makedepends=('python-setuptools' 'python2-setuptools' 'python-pytest' 'python2-pytest' 'python-requests' 'python2-requests')
source=("https://github.com/pallets/werkzeug/archive/${pkgver}.tar.gz")
-sha512sums=('e0a27fb37599bd93c9e3e282e1f7f8e2bc9c2be30cce32d1b8a9788cbf998c3337061ade1cbe76858a64da0ebc89112b905567d561354af1b7d86cbd9a56c27d')
+sha512sums=('71ec293b702f247b68bf82b4ff9e4351e21aa1949221c3cba46cd0db3c3f10ca2009029bf26869230ad32cec29109b279876b71f4aa0de64dd6635725c9baecb')
prepare() {
cp -r "werkzeug-$pkgver" "python-werkzeug-$pkgver"
cp -r "werkzeug-$pkgver" "python2-werkzeug-$pkgver"
}
-build_python-werkzeug() {
- cd "$pkgname-$pkgver"
+build() {
+ cd "$srcdir/python-werkzeug-$pkgver"
python setup.py build
-}
-build_python2-werkzeug() {
- cd "$pkgname-$pkgver"
+ cd "$srcdir/python2-werkzeug-$pkgver"
python2 setup.py build
}
-#check() {
-# cd "python-werkzeug-$pkgver"
-# python setup.py test
+# check() {
+# cd "python-werkzeug-$pkgver"
+# python setup.py test
#
-# cd "python-werkzeug-$pkgver"
-# p3ython2 setup.py test
-#}
+# cd "python2-werkzeug-$pkgver"
+# python2 setup.py test
+# }
package_python-werkzeug() {
- depends+=('python')
- cd "$pkgname-$pkgver"
+ depends=('python')
+ cd "python-werkzeug-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
package_python2-werkzeug() {
- depends+=('python2')
- cd "$pkgname-$pkgver"
+ depends=('python2')
+ cd "python2-werkzeug-$pkgver"
python2 setup.py install --root="$pkgdir" --optimize=1
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-# getver: https://github.com/mitsuhiko/werkzeug
# vim:set ts=2 sw=2 et:
diff --git a/abs/core/python_modules/python-werkzeug/__changelog b/abs/core/python_modules/python-werkzeug/__changelog
deleted file mode 100644
index 60db758..0000000
--- a/abs/core/python_modules/python-werkzeug/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-PKGBUILD: remove py3 stuff