summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-12-09 23:53:10 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-12-09 23:53:10 (GMT)
commite11217c7395798524faa21fdd4d203c03ab0bce9 (patch)
tree2f47c8cbcc8bed5d6aa34e3da516ecb5a62316d9 /abs/core/python_modules
parent0efa1e0fa590fa3b051497dd68dadc4faa959a73 (diff)
downloadlinhes_pkgbuild-e11217c7395798524faa21fdd4d203c03ab0bce9.zip
linhes_pkgbuild-e11217c7395798524faa21fdd4d203c03ab0bce9.tar.gz
linhes_pkgbuild-e11217c7395798524faa21fdd4d203c03ab0bce9.tar.bz2
python-oauth: recompile
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python-oauth/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/python_modules/python-oauth/PKGBUILD b/abs/core/python_modules/python-oauth/PKGBUILD
new file mode 100644
index 0000000..1404fec
--- /dev/null
+++ b/abs/core/python_modules/python-oauth/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Snowknight (hopkinsth@gmail.com)
+pkgname=python-oauth
+pkgver=1.0.1
+pkgrel=6
+pkgdesc="An open protocol to allow API authentication in a simple and standard method from desktop and web applications."
+arch=('any')
+url="http://code.google.com/p/oauth/"
+license=('MIT')
+depends=('python2')
+#makedepends=('python2-distribute')
+makedepends=('setuptools')
+source=(http://pypi.python.org/packages/source/o/oauth/oauth-${pkgver}.tar.gz)
+md5sums=('30ed3cc8c11d7841a89feab437aabf81')
+sha1sums=('b2d7609e4852b33d0d33f0bc6ae5cab8fadca014')
+
+build() {
+ cd ${srcdir}/oauth-${pkgver}
+
+ python2 setup.py build || return 1
+}
+package() {
+ cd ${srcdir}/oauth-${pkgver}
+ python2 setup.py install --root=${pkgdir} || return 1
+
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}
+