summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-04 22:05:11 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-04 22:05:11 (GMT)
commite15d07b28ec0e10e757a8b2c694d800a3a438615 (patch)
tree68dc390ddbee6096729357f737f1bb2dd8ea7a7c /abs/core/python_modules
parent913991a03e89df37ff273e0d25e201350834ecef (diff)
downloadlinhes_pkgbuild-e15d07b28ec0e10e757a8b2c694d800a3a438615.zip
linhes_pkgbuild-e15d07b28ec0e10e757a8b2c694d800a3a438615.tar.gz
linhes_pkgbuild-e15d07b28ec0e10e757a8b2c694d800a3a438615.tar.bz2
python2-m2crypto: dep of crda
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python2-m2crypto/LICENSE26
-rw-r--r--abs/core/python_modules/python2-m2crypto/PKGBUILD29
-rw-r--r--abs/core/python_modules/python2-m2crypto/openssl-1.1.0-force.patch33
3 files changed, 88 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-m2crypto/LICENSE b/abs/core/python_modules/python2-m2crypto/LICENSE
new file mode 100644
index 0000000..d2f636f
--- /dev/null
+++ b/abs/core/python_modules/python2-m2crypto/LICENSE
@@ -0,0 +1,26 @@
+Copyright (c) 1999-2004 Ng Pheng Siong. All rights reserved.
+
+Portions copyright (c) 2004-2006 Open Source Applications Foundation.
+All rights reserved.
+
+Portions copyright (c) 2005-2006 Vrije Universiteit Amsterdam.
+All rights reserved.
+
+Copyright (c) 2008-2010 Heikki Toivonen. All rights reserved.
+
+Permission to use, copy, modify, and distribute this software and its
+documentation for any purpose and without fee is hereby granted,
+provided that the above copyright notice appear in all copies and that
+both that copyright notice and this permission notice appear in
+supporting documentation.
+
+THE AUTHOR PROVIDES THIS SOFTWARE ``AS IS'' AND ANY EXPRESSED OR
+IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/abs/core/python_modules/python2-m2crypto/PKGBUILD b/abs/core/python_modules/python2-m2crypto/PKGBUILD
new file mode 100644
index 0000000..36d5f9b
--- /dev/null
+++ b/abs/core/python_modules/python2-m2crypto/PKGBUILD
@@ -0,0 +1,29 @@
+# $Id: PKGBUILD 140196 2011-10-09 08:27:16Z angvp $
+# Maintainer: Angel Velasquez <angvp@archlinux.org>
+# Contributor: Sergej Pupykin <sergej@aur.archlinux.org>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=python2-m2crypto
+pkgver=0.27.0
+pkgrel=1
+pkgdesc="A crypto and SSL toolkit for Python"
+arch=('x86_64')
+url="https://pypi.python.org/pypi/M2Crypto"
+license=('BSD')
+depends=('python2' 'openssl' 'python2-typing')
+makedepends=('swig' 'python2-setuptools')
+source=("https://pypi.python.org/packages/01/bd/a41491718f9e2bebab015c42b5be7071c6695acfa301e3fc0480bfd6a15b/M2Crypto-$pkgver.tar.gz"
+ "LICENSE")
+sha256sums=('82317459d653322d6b37f122ce916dc91ddcd9d1b814847497ac796c4549dd68'
+ '4eca478396f4b2b020729a111fce3f096456d74500bfd8f2b0388c3c69f997c0')
+
+build() {
+ cd "${srcdir}/M2Crypto-${pkgver}"
+ python2 setup.py build
+}
+
+package() {
+ cd "${srcdir}/M2Crypto-${pkgver}"
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 "$srcdir"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/abs/core/python_modules/python2-m2crypto/openssl-1.1.0-force.patch b/abs/core/python_modules/python2-m2crypto/openssl-1.1.0-force.patch
new file mode 100644
index 0000000..3c37702
--- /dev/null
+++ b/abs/core/python_modules/python2-m2crypto/openssl-1.1.0-force.patch
@@ -0,0 +1,33 @@
+--- M2Crypto-0.25.1/setup.py 2016-07-22 14:43:17.000000000 +0200
++++ M2Crypto-0.25.1.dirty/setup.py 2017-03-23 18:18:35.128517781 +0100
+@@ -70,8 +70,8 @@
+ self.libraries = ['ssleay32', 'libeay32']
+ self.openssl = 'c:\\pkg'
+ else:
+- self.libraries = ['ssl', 'crypto']
+- self.openssl = '/usr'
++ self.libraries = [':libssl.so.1.0.0', ':libcrypto.so.1.0.0']
++ self.openssl = '/usr/lib/openssl-1.0/'
+
+ def finalize_options(self):
+ '''Overloaded build_ext implementation to append custom openssl
+@@ -87,16 +87,11 @@
+ if _openssl and os.path.isdir(_openssl):
+ self.openssl = _openssl
+
+- self.include_dirs.append(os.path.join(self.openssl, 'include'))
+- openssl_library_dir = os.path.join(self.openssl, 'lib')
++ self.include_dirs.append(os.path.join('/usr/include/', 'openssl-1.0'))
++
++ openssl_library_dir = os.path.join('/usr/lib/', 'openssl-1.0')
+
+ if platform.system() == "Linux":
+- if _multiarch: # on Fedora/RHEL it is an empty string
+- self.include_dirs.append(
+- os.path.join(self.openssl, 'include', _multiarch))
+- else:
+- self.include_dirs.append(
+- os.path.join(self.openssl, 'include', 'openssl'))
+
+ # For RedHat-based distros, the '-D__{arch}__' option for
+ # Swig needs to be normalized, particularly on i386.