summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2017-07-15 23:06:50 (GMT)
committerBritney Fransen <brfransen@gmail.com>2017-07-15 23:06:50 (GMT)
commitea61ccf3c73bca9995ad0092522fdff98b3a1925 (patch)
tree6f11a322e748248a5777d9022aa9923ccba22c36 /abs/core/python_modules
parent80085a7177f1ced3e90fe0c62e49adbfe4023acb (diff)
downloadlinhes_pkgbuild-ea61ccf3c73bca9995ad0092522fdff98b3a1925.zip
linhes_pkgbuild-ea61ccf3c73bca9995ad0092522fdff98b3a1925.tar.gz
linhes_pkgbuild-ea61ccf3c73bca9995ad0092522fdff98b3a1925.tar.bz2
python2-paver: initial inclusion. dep of flexget
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/python2-paver/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/abs/core/python_modules/python2-paver/PKGBUILD b/abs/core/python_modules/python2-paver/PKGBUILD
new file mode 100644
index 0000000..328f6df
--- /dev/null
+++ b/abs/core/python_modules/python2-paver/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Sebastien Leduc <sebastien@sleduc.fr>
+# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
+
+pkgname=python2-paver
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Build, Distribute and Deploy Python Projects"
+arch=('i686' 'x86_64')
+url="http://www.blueskyonmars.com/projects/paver/"
+license=('BSD')
+depends=('python2')
+source=("http://pypi.python.org/packages/source/P/Paver/Paver-${pkgver}.tar.gz")
+md5sums=('dbb94faf8b004eb9920b632808c20560')
+
+package() {
+ cd "${srcdir}/Paver-${pkgver}"
+ python2 setup.py install --prefix="${pkgdir}/usr"
+ install -D "${srcdir}/Paver-${pkgver}/LICENSE.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+
+ # fix python3 conflict
+ for _f in "$pkgdir"/usr/bin/*; do
+ mv -v "$_f" "${_f}2"
+ done
+}