summaryrefslogtreecommitdiffstats
path: root/abs/core/python_modules
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-28 00:25:25 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-28 00:25:25 (GMT)
commitf3545e30a1769e837306673fc8cf5556b536031a (patch)
treeded2c957ef598eacdd4bfbf8e515126f4de1a8f9 /abs/core/python_modules
parent37d5024cdc7235a6a2ca2974863414b89e72fb5a (diff)
downloadlinhes_pkgbuild-f3545e30a1769e837306673fc8cf5556b536031a.zip
linhes_pkgbuild-f3545e30a1769e837306673fc8cf5556b536031a.tar.gz
linhes_pkgbuild-f3545e30a1769e837306673fc8cf5556b536031a.tar.bz2
pyqt: remove; replaced by pyqt5
Diffstat (limited to 'abs/core/python_modules')
-rw-r--r--abs/core/python_modules/pyqt/PKGBUILD99
-rw-r--r--abs/core/python_modules/pyqt/__changelog1
-rw-r--r--abs/core/python_modules/pyqt/fix-pyuic4.patch91
3 files changed, 0 insertions, 191 deletions
diff --git a/abs/core/python_modules/pyqt/PKGBUILD b/abs/core/python_modules/pyqt/PKGBUILD
deleted file mode 100644
index 669bc4c..0000000
--- a/abs/core/python_modules/pyqt/PKGBUILD
+++ /dev/null
@@ -1,99 +0,0 @@
-# $Id: PKGBUILD 163679 2012-07-17 18:11:04Z andrea $
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
-# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
-# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
-
-pkgbase=pyqt
-pkgname=('pyqt-common' 'python2-pyqt')
-pkgver=4.9.4
-pkgrel=2
-arch=('i686' 'x86_64')
-url="http://riverbankcomputing.co.uk/software/pyqt/intro"
-license=('GPL')
-makedepends=('qt' 'python2-sip'
- 'python-opengl' 'qt-assistant-compat' 'qtwebkit' 'python2-dbus')
-source=("http://riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-${pkgver}.tar.gz"
- 'fix-pyuic4.patch')
-md5sums=('a0b6a820633366365af5124ddbd059c7'
- '097651aea0bafded5abdfd6d62afd2ad')
-
-build() {
- # FS#30728
- cd "${srcdir}"/PyQt-x11-gpl-${pkgver}
- patch -p1 -i "${srcdir}"/fix-pyuic4.patch
- cd ..
-
- cp -r PyQt-x11-gpl-${pkgver} Py2Qt-x11-gpl-${pkgver}
-
- #cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
- #python configure.py \
- # --confirm-license \
- # --qsci-api
-
- # Thanks Gerardo for the rpath fix
- #find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
-
- #make
-
- ### Python2 version ###
- cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
- python2 configure.py \
- --confirm-license \
- -v /usr/share/sip \
- --qsci-api
-
- # Thanks Gerardo for the rpath fix
- find -name 'Makefile' | xargs sed -i 's|-Wl,-rpath,/usr/lib||g;s|-Wl,-rpath,.* ||g'
-
- make
-}
-
-package_pyqt-common(){
- pkgdesc="Common PyQt files shared between pyqt and python2-pyqt"
-
- cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
- make -C pyrcc DESTDIR="${pkgdir}" install
- make -C pylupdate DESTDIR="${pkgdir}" install
- make -C designer INSTALL_ROOT="${pkgdir}" install
-
- install -Dm644 PyQt4.api "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
-}
-
-package_pyqt(){
- pkgdesc="A set of Python 3.x bindings for the Qt toolkit"
- depends=('qtwebkit' 'python-sip' 'python-dbus' 'pyqt-common')
- optdepends=('phonon: enable audio and video in PyQt applications'
- 'qscintilla: QScintilla API'
- 'qt-assistant-compat: add PyQt online help in Qt Assistant')
-
- cd "${srcdir}/PyQt-x11-gpl-${pkgver}"
- # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-
- # Provided by pyqt-common
- rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
- rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
- rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
-}
-
-package_python2-pyqt(){
- pkgdesc="A set of Python 2.x bindings for the Qt toolkit"
- depends=('qtwebkit' 'python2-sip' 'python2-dbus' 'pyqt-common')
- optdepends=('phonon: enable audio and video in PyQt applications'
- 'python-opengl: enable OpenGL 3D graphics in PyQt applications'
- 'qscintilla: QScintilla API'
- 'qt-assistant-compat: add PyQt online help in Qt Assistant')
- provides=('python2-qt')
-
- cd "${srcdir}/Py2Qt-x11-gpl-${pkgver}"
- # INSTALL_ROOT is needed for the QtDesigner module, the other Makefiles use DESTDIR
- make DESTDIR="${pkgdir}" INSTALL_ROOT="${pkgdir}" install
-
- # Fix conflicts with pyqt
- mv "${pkgdir}"/usr/bin/{,python2-}pyuic4
-
- # Provided by pyqt-common
- rm "${pkgdir}"/usr/bin/{pylupdate4,pyrcc4}
- rm "${pkgdir}"/usr/lib/qt/plugins/designer/libpythonplugin.so
- rm "${pkgdir}"/usr/share/qt/qsci/api/python/PyQt4.api
-}
diff --git a/abs/core/python_modules/pyqt/__changelog b/abs/core/python_modules/pyqt/__changelog
deleted file mode 100644
index 9731eb3..0000000
--- a/abs/core/python_modules/pyqt/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-removed python3
diff --git a/abs/core/python_modules/pyqt/fix-pyuic4.patch b/abs/core/python_modules/pyqt/fix-pyuic4.patch
deleted file mode 100644
index 2173443..0000000
--- a/abs/core/python_modules/pyqt/fix-pyuic4.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-# HG changeset patch
-# User Phil Thompson <phil at riverbankcomputing.com>
-# Date 2012-07-13 13:39:28 +0100
-# Node ID 29b668ada14c1428a3bbfe8f0324c6626bd5ac9a
-# Parent fd0f3da9d79ca9858d10a20c15fb85456cb832d7
-Fixed a regression in pyuic's handling of custom widgets.
-
-diff --git a/pyuic/uic/Compiler/qobjectcreator.py b/pyuic/uic/Compiler/qobjectcreator.py
---- a/pyuic/uic/Compiler/qobjectcreator.py
-+++ b/pyuic/uic/Compiler/qobjectcreator.py
-@@ -1,6 +1,6 @@
- #############################################################################
- ##
--## Copyright (C) 2011 Riverbank Computing Limited.
-+## Copyright (C) 2012 Riverbank Computing Limited.
- ## Copyright (C) 2006 Thorsten Marek.
- ## All right reserved.
- ##
-@@ -100,7 +100,6 @@
- assert widgetClass not in self._widgets
- self._widgets[widgetClass] = (baseClass, module)
-
--
- def _resolveBaseclass(self, baseClass):
- try:
- for x in range(0, 10):
-@@ -114,19 +113,17 @@
- except KeyError:
- raise ValueError("unknown baseclass %s" % baseClass)
-
--
- def search(self, cls):
- try:
-- self._usedWidgets.add(cls)
- baseClass = self._resolveBaseclass(self._widgets[cls][0])
- DEBUG("resolved baseclass of %s: %s" % (cls, baseClass))
--
-- return type(cls, (baseClass,),
-- {"module" : ""})
--
- except KeyError:
- return None
-
-+ self._usedWidgets.add(cls)
-+
-+ return type(cls, (baseClass, ), {"module" : ""})
-+
- def _writeImportCode(self):
- imports = {}
- for widget in self._usedWidgets:
-diff --git a/pyuic/uic/objcreator.py b/pyuic/uic/objcreator.py
---- a/pyuic/uic/objcreator.py
-+++ b/pyuic/uic/objcreator.py
-@@ -102,19 +102,26 @@
- self._modules.append(self._customWidgets)
-
- def createQObject(self, classname, *args, **kwargs):
-- # Handle scoped names, typically static factory methods.
-- parts = classname.split('.')
-- factory = self.findQObjectType(parts[0])
-+ # Handle regular and custom widgets.
-+ factory = self.findQObjectType(classname)
-
-- if factory is not None:
-- for part in parts[1:]:
-- factory = getattr(factory, part, None)
-- if factory is None:
-- break
-- else:
-- return self._cpolicy.instantiate(factory, *args, **kwargs)
-+ if factory is None:
-+ # Handle scoped names, typically static factory methods.
-+ parts = classname.split('.')
-
-- raise NoSuchWidgetError(classname)
-+ if len(parts) > 1:
-+ factory = self.findQObjectType(parts[0])
-+
-+ if factory is not None:
-+ for part in parts[1:]:
-+ factory = getattr(factory, part, None)
-+ if factory is None:
-+ break
-+
-+ if factory is None:
-+ raise NoSuchWidgetError(classname)
-+
-+ return self._cpolicy.instantiate(factory, *args, **kwargs)
-
- def invoke(self, rname, method, args=()):
- return self._cpolicy.invoke(rname, method, args)