summaryrefslogtreecommitdiffstats
path: root/abs/core/qt4/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-02-03 14:46:14 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-02-03 14:46:14 (GMT)
commit8acb993e10b19feccf2f3743d2f1402bfdbef050 (patch)
tree8be41c9110db7fd101af1bbbcc7cb3d584b9dfba /abs/core/qt4/PKGBUILD
parentd57a352d5f6f9645e02e04a1cd0df8316a6daf01 (diff)
downloadlinhes_pkgbuild-8acb993e10b19feccf2f3743d2f1402bfdbef050.zip
linhes_pkgbuild-8acb993e10b19feccf2f3743d2f1402bfdbef050.tar.gz
linhes_pkgbuild-8acb993e10b19feccf2f3743d2f1402bfdbef050.tar.bz2
qt4: update to 4.8.7
Diffstat (limited to 'abs/core/qt4/PKGBUILD')
-rw-r--r--abs/core/qt4/PKGBUILD56
1 files changed, 38 insertions, 18 deletions
diff --git a/abs/core/qt4/PKGBUILD b/abs/core/qt4/PKGBUILD
index f045f76..db52f76 100644
--- a/abs/core/qt4/PKGBUILD
+++ b/abs/core/qt4/PKGBUILD
@@ -1,39 +1,45 @@
# $Id$
-# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Pierre Schmitz <pierre@archlinux.de>
pkgname=qt4
-pkgver=4.8.6
-pkgrel=3
+pkgver=4.8.7
+pkgrel=6
arch=('i686' 'x86_64')
-url='http://qt-project.org/'
+url='http://www.qt.io'
license=('GPL3' 'LGPL' 'FDL' 'custom')
pkgdesc='A cross-platform application and UI framework'
depends=('libtiff' 'libpng' 'sqlite' 'ca-certificates' 'dbus'
'fontconfig' 'libgl' 'libxrandr' 'libxv' 'libxi' 'alsa-lib'
'xdg-utils' 'hicolor-icon-theme' 'desktop-file-utils' 'libmng')
-makedepends=('mysql' 'unixodbc' 'gtk2'
+makedepends=('postgresql-libs' 'mysql' 'unixodbc' 'cups' 'gtk2' 'libfbclient'
'mesa')
optdepends=('qtchooser: set the default Qt toolkit'
- 'libmysqlclient: mysql driver'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmysqlclient: MySQL driver'
'unixodbc: ODBC driver'
'libfbclient: Firebird/iBase driver'
'libxinerama: Xinerama support'
'libxcursor: Xcursor support'
'libxfixes: Xfixes support'
- 'icu: Unicode support')
+ 'icu: Unicode support'
+ 'sni-qt: StatusNotifierItem (AppIndicators) support')
install="${pkgname}.install"
replaces=('qt<=4.8.4')
conflicts=('qt')
-options=('staticlibs') # libQtUiTools builds as static only
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/4.8/${pkgver}/${_pkgfqn}.tar.gz"
+source=("http://download.qt.io/official_releases/qt/4.8/${pkgver}/${_pkgfqn}.tar.gz"
'qtconfig-qt4.desktop' 'assistant-qt4.desktop' 'designer-qt4.desktop'
'linguist-qt4.desktop' 'qdbusviewer-qt4.desktop'
'improve-cups-support.patch'
'moc-boost-workaround.patch'
- 'CVE-2014-0190.patch')
-md5sums=('2edbe4d6c2eff33ef91732602f3518eb'
+ 'kubuntu_14_systemtrayicon.diff'
+ 'kde4-settings.patch'
+ 'glib-honor-ExcludeSocketNotifiers-flag.diff'
+ 'l-qclipboard_fix_recursive.patch'
+ 'l-qclipboard_delay.patch')
+md5sums=('d990ee66bf7ab0c785589776f35ba6ad'
'a16638f4781e56e7887ff8212a322ecc'
'8a28b3f52dbeb685d4b69440b520a3e1'
'9727c406c240990870c905696a8c5bd1'
@@ -41,7 +47,11 @@ md5sums=('2edbe4d6c2eff33ef91732602f3518eb'
'b859c5673e5098c39f72b2252947049e'
'c439c7731c25387352d8453ca7574971'
'da387bde22ae1c446f12525d2a31f070'
- '34ed257109afb83342cfe514c8abe027')
+ 'a523644faa8f98a73f55c4aa23c114a6'
+ '66dfea63916c8dbf47b23cb012ffdccc'
+ '85679531c8a7310317adfb7002d9f99a'
+ '009de09b4e589a7770fba74405656c99'
+ 'addc5e88d538ee55e17bd49ba337ca67')
prepare() {
cd ${_pkgfqn}
@@ -52,8 +62,19 @@ prepare() {
# QTBUG#22829
patch -p1 -i "${srcdir}"/moc-boost-workaround.patch
- # QTBUG#38367
- patch -p1 -i "${srcdir}"/CVE-2014-0190.patch
+ # http://blog.martin-graesslin.com/blog/2014/06/where-are-my-systray-icons/
+ patch -p1 -i "${srcdir}"/kubuntu_14_systemtrayicon.diff
+
+ # FS#45106
+ patch -p0 -i "${srcdir}"/kde4-settings.patch
+
+ # fixes for LibreOffice from the upstream Qt bug tracker FS#46436, FS#41648, FS#39819
+ # https://bugreports.qt.io/browse/QTBUG-37380
+ patch -p1 -i "${srcdir}"/glib-honor-ExcludeSocketNotifiers-flag.diff
+ # https://bugreports.qt.io/browse/QTBUG-34614
+ patch -p0 -i "${srcdir}"/l-qclipboard_fix_recursive.patch
+ # https://bugreports.qt.io/browse/QTBUG-38585
+ patch -p0 -i "${srcdir}"/l-qclipboard_delay.patch
sed -i "s|-O2|${CXXFLAGS}|" mkspecs/common/{g++,gcc}-base.conf
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" mkspecs/common/gcc-base-unix.conf
@@ -82,7 +103,7 @@ build() {
-sysconfdir /etc/xdg \
-examplesdir /usr/share/doc/qt4/examples \
-demosdir /usr/share/doc/qt4/demos \
- -plugin-sql-{mysql,sqlite,odbc} \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
-system-sqlite \
-no-phonon \
-no-phonon-backend \
@@ -95,10 +116,9 @@ build() {
-silent \
-no-rpath \
-optimized-qmake \
- -reduce-relocations \
+ -no-reduce-relocations \
-dbus-linked \
- -no-openvg \
- -v
+ -no-openvg
make
}