summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5-base
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-20 21:51:58 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-20 21:51:58 (GMT)
commit271ac76a9b6f96f91b4b18e1e20068f1b7e2a544 (patch)
tree67d0995526e4275ddb9c8354b4f3e62caede8790 /abs/core/qt5-base
parent7d170562cfb13aaf5a122cda079f186634ab5e09 (diff)
downloadlinhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.zip
linhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.tar.gz
linhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.tar.bz2
qt5: update to 5.10.1
Diffstat (limited to 'abs/core/qt5-base')
-rw-r--r--abs/core/qt5-base/PKGBUILD119
-rw-r--r--abs/core/qt5-base/__changelog3
-rw-r--r--abs/core/qt5-base/qtbug-65478.patch31
-rw-r--r--abs/core/qt5-base/rebuild.list25
-rw-r--r--abs/core/qt5-base/revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch71
5 files changed, 249 insertions, 0 deletions
diff --git a/abs/core/qt5-base/PKGBUILD b/abs/core/qt5-base/PKGBUILD
new file mode 100644
index 0000000..1cb9883
--- /dev/null
+++ b/abs/core/qt5-base/PKGBUILD
@@ -0,0 +1,119 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgbase=qt5-base
+pkgname=(qt5-base qt5-xcb-private-headers)
+_qtver=5.10.1
+pkgver=${_qtver/-/}
+pkgrel=3
+arch=('x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='A cross-platform application and UI framework'
+depends=('libjpeg-turbo' 'xcb-util-keysyms' 'xcb-util-renderutil' 'libgl' 'fontconfig' 'xdg-utils'
+ 'xcb-util-wm' 'libxrender' 'libxi' 'sqlite' 'xcb-util-image' 'icu' 'pcre2'
+ 'libinput' 'libsm' 'libxkbcommon-x11' 'libproxy' 'libcups' 'double-conversion')
+makedepends=('libfbclient' 'libmysqlclient' 'sqlite' 'unixodbc' 'postgresql-libs' 'alsa-lib' 'gst-plugins-base-libs'
+ 'gtk3' 'cups' 'freetds' 'vulkan-headers')
+optdepends=('qt5-svg: to use SVG icon themes'
+ 'postgresql-libs: PostgreSQL driver'
+ 'libmysqlclient: mysql driver'
+ 'unixodbc: ODBC driver'
+ 'libfbclient: Firebird/iBase driver'
+ 'freetds: MS SQL driver'
+ 'gtk3: GTK platform plugin')
+conflicts=('qtchooser')
+groups=('qt' 'qt5')
+_pkgfqn="${pkgbase/5-/}-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
+ qtbug-65478.patch)
+sha256sums=('d8660e189caa5da5142d5894d328b61a4d3ee9750b76d61ad74e4eee8765a969'
+ '7161ea5747500dc9666f8d185f4b8e538799fc0aef574e577277747100ac4763'
+ 'b2e8cb06c60be7de31a984c4cfc9ab85c9e2d08c1a3d93136f193735b43600c6')
+
+prepare() {
+ cd ${_pkgfqn}
+
+ # Build qmake using Arch {C,LD}FLAGS
+ # This also sets default {C,CXX,LD}FLAGS for projects built using qmake
+ sed -i -e "s|^\(QMAKE_CFLAGS_RELEASE.*\)|\1 ${CFLAGS}|" \
+ mkspecs/common/gcc-base.conf
+ sed -i -e "s|^\(QMAKE_LFLAGS_RELEASE.*\)|\1 ${LDFLAGS}|" \
+ mkspecs/common/g++-unix.conf
+
+ # Use python2 for Python 2.x
+ find . -name '*.py' -exec sed -i \
+ 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|' {} +
+
+ # Fix missing private includes https://bugreports.qt.io/browse/QTBUG-37417
+ sed -e '/CMAKE_NO_PRIVATE_INCLUDES\ \=\ true/d' -i mkspecs/features/create_cmake.prf
+
+ # Revert upstream commit which breaks some Deepin components (FS#57531)
+ # https://bugreports.qt.io/browse/QTBUG-66226
+ patch -Np1 -i ../revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
+ # Fix kexi crash at startup http://bugreports.qt.io/browse/QTBUG-65478
+ patch -p1 -i ../qtbug-65478.patch
+}
+
+build() {
+ cd ${_pkgfqn}
+
+ PYTHON=/usr/bin/python2 ./configure -confirm-license -opensource -v \
+ -prefix /usr \
+ -docdir /usr/share/doc/qt \
+ -headerdir /usr/include/qt \
+ -archdatadir /usr/lib/qt \
+ -datadir /usr/share/qt \
+ -sysconfdir /etc/xdg \
+ -examplesdir /usr/share/doc/qt/examples \
+ -plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
+ -system-sqlite \
+ -openssl-linked \
+ -nomake examples \
+ -no-rpath \
+ -optimized-qmake \
+ -dbus-linked \
+ -system-harfbuzz \
+ -journald \
+ -no-use-gold-linker \
+ -reduce-relocations
+ make
+}
+
+package_qt5-base() {
+ pkgdesc='A cross-platform application and UI framework'
+
+ cd ${_pkgfqn}
+ make INSTALL_ROOT="${pkgdir}" install
+
+ install -D -m644 LGPL_EXCEPTION.txt \
+ "${pkgdir}"/usr/share/licenses/${pkgbase}/LGPL_EXCEPTION.txt
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ # Fix wrong qmake path in pri file
+ sed -i "s|${srcdir}/${_pkgfqn}|/usr|" \
+ "${pkgdir}"/usr/lib/qt/mkspecs/modules/qt_lib_bootstrap_private.pri
+
+ # Symlinks for backwards compatibility
+ for b in "${pkgdir}"/usr/bin/*; do
+ ln -s /usr/bin/$(basename $b) "${pkgdir}"/usr/bin/$(basename $b)-qt5
+ done
+}
+
+package_qt5-xcb-private-headers() {
+ pkgdesc='Private headers for Qt5 Xcb'
+
+ depends=("qt5-base=$pkgver")
+ optdepends=()
+ groups=()
+ conflicts=()
+
+ cd ${_pkgfqn}
+ install -d -m755 "$pkgdir"/usr/include/qtxcb-private
+ cp -r src/plugins/platforms/xcb/*.h "$pkgdir"/usr/include/qtxcb-private/
+}
diff --git a/abs/core/qt5-base/__changelog b/abs/core/qt5-base/__changelog
new file mode 100644
index 0000000..4049625
--- /dev/null
+++ b/abs/core/qt5-base/__changelog
@@ -0,0 +1,3 @@
+PKGBUILD:
+- remove dep libpulse
+- changed libmaria to libmysql
diff --git a/abs/core/qt5-base/qtbug-65478.patch b/abs/core/qt5-base/qtbug-65478.patch
new file mode 100644
index 0000000..e75069c
--- /dev/null
+++ b/abs/core/qt5-base/qtbug-65478.patch
@@ -0,0 +1,31 @@
+From e8425f9e52c9df0ce0fbf122adff3ef6930f9961 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Thorbj=C3=B8rn=20Lund=20Martsum?= <tmartsum@gmail.com>
+Date: Wed, 28 Feb 2018 09:23:54 +0100
+Subject: QHeaderView: Fix crash in layout about to change
+
+Before there was a risk looking up e.g index -1 if there
+were no visible sections in layoutAboutToChange.
+
+Change-Id: Ic911e4292e8e8c4892fef1c0f34cf7dccaad2bac
+Task-number: QTBUG-65478
+Reviewed-by: David Faure <david.faure@kdab.com>
+---
+diff --git a/src/widgets/itemviews/qheaderview.cpp b/src/widgets/itemviews/qheaderview.cpp
+index 26d7c5472a..708b9b44ca 100644
+--- a/src/widgets/itemviews/qheaderview.cpp
++++ b/src/widgets/itemviews/qheaderview.cpp
+@@ -2163,9 +2163,11 @@ void QHeaderViewPrivate::_q_sectionsAboutToBeChanged()
+ layoutChangePersistentSections.clear();
+ layoutChangePersistentSections.reserve(std::min(10, sectionItems.count()));
+ // after layoutChanged another section can be last stretched section
+- if (stretchLastSection) {
++ if (stretchLastSection && lastSectionLogicalIdx >= 0 && lastSectionLogicalIdx < sectionItems.count()) {
+ const int visual = visualIndex(lastSectionLogicalIdx);
+- sectionItems[visual].size = lastSectionSize;
++ if (visual >= 0 && visual < sectionItems.size()) {
++ sectionItems[visual].size = lastSectionSize;
++ }
+ }
+ for (int i = 0; i < sectionItems.size(); ++i) {
+ auto s = sectionItems.at(i);
+
diff --git a/abs/core/qt5-base/rebuild.list b/abs/core/qt5-base/rebuild.list
new file mode 100644
index 0000000..fdb9fec
--- /dev/null
+++ b/abs/core/qt5-base/rebuild.list
@@ -0,0 +1,25 @@
+### Rebuild only for minor version updates
+calibre
+gcin
+kwin
+lxqt-qtplugin
+plasma-framework
+plasma-integration
+qqc2-desktop-style
+qt5ct
+### Rebuild for minor and patch version updates
+akonadi
+deepin-dock
+deepin-file-manager
+deepin-qt-dbus-factory
+deepin-qt5integration
+deepin-qt5dxcb-plugin
+dtkwidget
+dtkwm
+fcitx-qt5
+googlemaps
+libqtxdg
+pyqt5-common
+qt5-styleplugins
+qt5-webkit
+skrooge
diff --git a/abs/core/qt5-base/revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch b/abs/core/qt5-base/revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
new file mode 100644
index 0000000..da692d0
--- /dev/null
+++ b/abs/core/qt5-base/revert-Set-sharedPainter-correctly-for-QGraphicsEffect.patch
@@ -0,0 +1,71 @@
+From f4bc1f620727366b6a977b106cc68fade95ef426 Mon Sep 17 00:00:00 2001
+From: Evangelos Foutras <evangelos@foutrelis.com>
+Date: Wed, 21 Feb 2018 04:20:20 +0200
+Subject: [PATCH] Revert "Set sharedPainter correctly for QGraphicsEffect"
+
+This reverts commit 7257862fb2edfab0219d6cd45c83677049404f7d.
+---
+ src/widgets/kernel/qwidget.cpp | 4 ++--
+ .../effects/qgraphicseffect/tst_qgraphicseffect.cpp | 21 ---------------------
+ 2 files changed, 2 insertions(+), 23 deletions(-)
+
+diff --git a/src/widgets/kernel/qwidget.cpp b/src/widgets/kernel/qwidget.cpp
+index a973bee2cd..256c77e5a0 100644
+--- a/src/widgets/kernel/qwidget.cpp
++++ b/src/widgets/kernel/qwidget.cpp
+@@ -5482,11 +5482,11 @@ void QWidgetPrivate::drawWidget(QPaintDevice *pdev, const QRegion &rgn, const QP
+ setSystemClip(pdev->paintEngine(), pdev->devicePixelRatioF(), rgn.translated(offset));
+ QPainter p(pdev);
+ p.translate(offset);
+- context.painter = context.sharedPainter = &p;
++ context.painter = &p;
+ graphicsEffect->draw(&p);
+ setSystemClip(pdev->paintEngine(), 1, QRegion());
+ } else {
+- context.painter = context.sharedPainter = sharedPainter;
++ context.painter = sharedPainter;
+ if (sharedPainter->worldTransform() != sourced->lastEffectTransform) {
+ sourced->invalidateCache();
+ sourced->lastEffectTransform = sharedPainter->worldTransform();
+diff --git a/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp b/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
+index dfe5baba71..a1cb729849 100644
+--- a/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
++++ b/tests/auto/widgets/effects/qgraphicseffect/tst_qgraphicseffect.cpp
+@@ -52,7 +52,6 @@ private slots:
+ void boundingRect2();
+ void draw();
+ void opacity();
+- void nestedOpaqueOpacity();
+ void grayscale();
+ void colorize();
+ void drawPixmapItem();
+@@ -408,26 +407,6 @@ void tst_QGraphicsEffect::opacity()
+ QCOMPARE(effect->m_opacity, qreal(0.5));
+ }
+
+-void tst_QGraphicsEffect::nestedOpaqueOpacity()
+-{
+- // QTBUG-60231: Nesting widgets with a QGraphicsEffect on a toplevel with
+- // QGraphicsOpacityEffect caused crashes due to constructing several
+- // QPainter instances on a device in the fast path for
+- // QGraphicsOpacityEffect::opacity=1
+- QWidget topLevel;
+- topLevel.setWindowTitle(QTest::currentTestFunction());
+- topLevel.resize(320, 200);
+- QGraphicsOpacityEffect *opacityEffect = new QGraphicsOpacityEffect;
+- opacityEffect->setOpacity(1);
+- topLevel.setGraphicsEffect(opacityEffect);
+- QWidget *child = new QWidget(&topLevel);
+- child->resize(topLevel.size() / 2);
+- QGraphicsDropShadowEffect *childEffect = new QGraphicsDropShadowEffect;
+- child->setGraphicsEffect(childEffect);
+- topLevel.show();
+- QVERIFY(QTest::qWaitForWindowExposed(&topLevel));
+-}
+-
+ void tst_QGraphicsEffect::grayscale()
+ {
+ if (qApp->desktop()->depth() < 24)
+--
+2.16.2
+