summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5-imageformats
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-20 21:51:58 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-20 21:51:58 (GMT)
commit271ac76a9b6f96f91b4b18e1e20068f1b7e2a544 (patch)
tree67d0995526e4275ddb9c8354b4f3e62caede8790 /abs/core/qt5-imageformats
parent7d170562cfb13aaf5a122cda079f186634ab5e09 (diff)
downloadlinhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.zip
linhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.tar.gz
linhes_pkgbuild-271ac76a9b6f96f91b4b18e1e20068f1b7e2a544.tar.bz2
qt5: update to 5.10.1
Diffstat (limited to 'abs/core/qt5-imageformats')
-rw-r--r--abs/core/qt5-imageformats/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/abs/core/qt5-imageformats/PKGBUILD b/abs/core/qt5-imageformats/PKGBUILD
new file mode 100644
index 0000000..90e39f7
--- /dev/null
+++ b/abs/core/qt5-imageformats/PKGBUILD
@@ -0,0 +1,37 @@
+# $Id: PKGBUILD 240297 2015-06-03 10:22:03Z fyan $
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=qt5-imageformats
+_qtver=5.10.1
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=('x86_64')
+url='http://qt-project.org/'
+license=('GPL3' 'LGPL3' 'FDL' 'custom')
+pkgdesc='Plugins for additional image formats: TIFF, MNG, TGA, WBMP'
+depends=('qt5-base' 'jasper' 'libmng' 'libwebp')
+makedepends=()
+groups=('qt' 'qt5')
+_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('2804baa2779eae015096820e233d7f86bb7fde9853b7c9150a321a453422a283')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake ../${_pkgfqn}
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
+}