summaryrefslogtreecommitdiffstats
path: root/abs/core/qt5-networkauth
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-26 17:37:35 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-26 17:37:35 (GMT)
commit776abc483e0e183211b6fb2713b5dee8f7c3a811 (patch)
treec1cdcc5ce862b76076e83f731b604fe0a45e2073 /abs/core/qt5-networkauth
parent245f231c20bd4efa072bbc13d86e63ed0b129a04 (diff)
downloadlinhes_pkgbuild-776abc483e0e183211b6fb2713b5dee8f7c3a811.zip
linhes_pkgbuild-776abc483e0e183211b6fb2713b5dee8f7c3a811.tar.gz
linhes_pkgbuild-776abc483e0e183211b6fb2713b5dee8f7c3a811.tar.bz2
qt5-networkauth: update to 5.10.1
Diffstat (limited to 'abs/core/qt5-networkauth')
-rw-r--r--abs/core/qt5-networkauth/PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/abs/core/qt5-networkauth/PKGBUILD b/abs/core/qt5-networkauth/PKGBUILD
new file mode 100644
index 0000000..db17b48
--- /dev/null
+++ b/abs/core/qt5-networkauth/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Antonio Rojas <arojas@archlinux.org>
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+
+pkgname=qt5-networkauth
+_qtver=5.10.1
+pkgver=${_qtver/-/}
+pkgrel=1
+arch=(x86_64)
+url='http://qt-project.org/'
+license=(GPL3 LGPL3 FDL custom)
+pkgdesc='Network authentication module'
+depends=(qt5-base)
+groups=(qt qt5)
+_pkgfqn="${pkgname/5-/}-everywhere-src-${_qtver}"
+source=("http://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
+sha256sums=('97231c319bd623d81eebaa1b5cdba4064bc4e69332c695a15cf8792b54b5dcdc')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+
+ qmake ../${_pkgfqn}
+ make
+}
+
+package() {
+ cd build
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
+}