summaryrefslogtreecommitdiffstats
path: root/abs/core/rpcbind/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <jams@linhes.org>2010-12-13 01:11:37 (GMT)
committerJames Meyer <jams@linhes.org>2010-12-13 01:11:37 (GMT)
commitb2ad14ffbef9ee223c4ce41235aa0af77d61053c (patch)
treeacf4d2728472300b0964826d3eca3e565b9f225f /abs/core/rpcbind/PKGBUILD
parent5f0cec38c5d521dfc11d9d0c283fc37ef972766e (diff)
downloadlinhes_pkgbuild-b2ad14ffbef9ee223c4ce41235aa0af77d61053c.zip
linhes_pkgbuild-b2ad14ffbef9ee223c4ce41235aa0af77d61053c.tar.gz
linhes_pkgbuild-b2ad14ffbef9ee223c4ce41235aa0af77d61053c.tar.bz2
rpcbind: apply patch so that it registers as sunrpc in /etc/services
Diffstat (limited to 'abs/core/rpcbind/PKGBUILD')
-rw-r--r--abs/core/rpcbind/PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/abs/core/rpcbind/PKGBUILD b/abs/core/rpcbind/PKGBUILD
index 11d8a91..81d6254 100644
--- a/abs/core/rpcbind/PKGBUILD
+++ b/abs/core/rpcbind/PKGBUILD
@@ -1,24 +1,28 @@
-# $Id: PKGBUILD 54912 2009-10-11 20:12:23Z giovanni $
+# $Id: PKGBUILD 86473 2010-08-02 07:44:00Z tpowa $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
pkgname=rpcbind
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="portmap replacement which supports RPC over various protocols"
arch=(i686 x86_64)
depends=('bash' 'glibc' 'libtirpc')
url="http://rpcbind.sourceforge.net"
license=('custom')
replaces=('portmap')
-source=(http://downloads.sourceforge.net/sourceforge/rpcbind/rpcbind-0.2.0.tar.bz2
+source=(http://downloads.sourceforge.net/sourceforge/rpcbind/rpcbind-0.2.0.tar.bz2
+ rpcbind-sunrpc.patch
rpcbind)
md5sums=('1a77ddb1aaea8099ab19c351eeb26316'
+ 'c02ac36a98baac70b8a26190524b7b73'
'78a963654f57cbb209e228884767836e')
build() {
cd $srcdir/$pkgname-$pkgver
+ # patch for iana services file
+ patch -Np1 -i ../rpcbind-sunrpc.patch
./configure --prefix=/usr
- make || return 1
- make DESTDIR=$pkgdir install || return 1
+ make
+ make DESTDIR=$pkgdir install
# install daemon
install -D -m755 $srcdir/rpcbind $pkgdir/etc/rc.d/rpcbind
# install license