summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-05 22:30:31 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-05 22:30:31 (GMT)
commit9649ae208248fc14b44dde67d6bc7301127d9f4c (patch)
treeb95348b8ebcb96c8978ea8bce39a6fb822d76415 /abs/core/runit-scripts/PKGBUILD
parentbdefc1e81c89dbb12e7e914a9f1f220ee5ed1714 (diff)
downloadlinhes_pkgbuild-9649ae208248fc14b44dde67d6bc7301127d9f4c.zip
linhes_pkgbuild-9649ae208248fc14b44dde67d6bc7301127d9f4c.tar.gz
linhes_pkgbuild-9649ae208248fc14b44dde67d6bc7301127d9f4c.tar.bz2
runit-scripts: fix frontend respawn by shutting down all services in 3. refs #961
add pause utility from ignite project remove power script stuff as it is done in poweroff-scripts
Diffstat (limited to 'abs/core/runit-scripts/PKGBUILD')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD18
1 files changed, 14 insertions, 4 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 9b32d76..ed76902 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,20 +1,26 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=10
+pkgrel=11
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
depends=('glibc' 'util-linux' 'initscripts' 'runit' )
-makedepends=('rsync')
+makedepends=('gcc' 'make' 'rsync')
conflicts=()
replaces=()
backup=('etc/runit/1.local' 'etc/runit/3.local')
install=runit.install
-source=('fbsplash-runit.sh')
+source=('fbsplash-runit.sh'
+ 'http://chneukirchen.org/releases/ignite-0.9.0.tar.gz')
arch=('i686' 'x86_64')
build() {
rsync -a --exclude=.svn --exclude=*~ $startdir/runitscripts $srcdir
+
+ #build pause util from ignite
+ cd $srcdir/ignite-0.9.0/util
+ sed -i 's/musl-gcc/gcc/g' ./Makefile
+ make
}
package() {
@@ -34,5 +40,9 @@ package() {
rsync -a --exclude=.svn services/* $pkgdir/etc/sv
chmod -R 755 $pkgdir/etc/sv
chown -R root:root $pkgdir/etc/sv
+
+ install -D -m0755 $srcdir/ignite-0.9.0/util/pause $pkgdir/usr/bin/pause
+ install -D -m0644 $srcdir/ignite-0.9.0/util/pause.1 $pkgdir/usr/share/man/man1/pause.1
}
-md5sums=('30b944b91aa1f57c5469c8bd210cb497')
+md5sums=('30b944b91aa1f57c5469c8bd210cb497'
+ '1d88cf79d810e7d371e713f724fa2e85')