summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-25 04:13:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-25 04:13:08 (GMT)
commit08741c3cc09fadb3ebfa8ea92d3e5160c20990e4 (patch)
treec323cfd1b0de3f8fe1baff532f87db1448690664 /abs/core/runit-scripts
parent68f2e7fce1e049c990be3312f8d4261f352efb5a (diff)
downloadlinhes_pkgbuild-08741c3cc09fadb3ebfa8ea92d3e5160c20990e4.zip
linhes_pkgbuild-08741c3cc09fadb3ebfa8ea92d3e5160c20990e4.tar.gz
linhes_pkgbuild-08741c3cc09fadb3ebfa8ea92d3e5160c20990e4.tar.bz2
runit-scripts: added svc for vnc
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/vnc/finish9
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/vnc/run12
3 files changed, 22 insertions, 1 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 8957212..f1fb053 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=66
+pkgrel=67
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/vnc/finish b/abs/core/runit-scripts/runitscripts/services/vnc/finish
new file mode 100755
index 0000000..e5db2ab
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/vnc/finish
@@ -0,0 +1,9 @@
+#!/bin/sh
+#set -x
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Stopping vnc service"
+
+su vncsvc -c "vncserver -kill :1" \ No newline at end of file
diff --git a/abs/core/runit-scripts/runitscripts/services/vnc/run b/abs/core/runit-scripts/runitscripts/services/vnc/run
new file mode 100755
index 0000000..c621c2c
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/vnc/run
@@ -0,0 +1,12 @@
+#!/bin/sh
+#set -x
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting vnc service"
+geometry=1024x768
+#. /etc/conf.d/vncserver 2>/dev/null
+
+exec su vncsvc -c "/usr/bin/vncserver -fg -geometry $geometry :1"
+