summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-11 01:47:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-11 01:47:45 (GMT)
commit0baf997ee6184fe49968687d93205b34323af16f (patch)
tree153043c7c3065d798d6a1639221a1e40ff967d0c /abs/core/runit-scripts
parent278bada9f44111056f2e175629c7761d5a0b9755 (diff)
downloadlinhes_pkgbuild-0baf997ee6184fe49968687d93205b34323af16f.zip
linhes_pkgbuild-0baf997ee6184fe49968687d93205b34323af16f.tar.gz
linhes_pkgbuild-0baf997ee6184fe49968687d93205b34323af16f.tar.bz2
runit-scripts: add exec to mythexpress and remyth. Without the exec sv stop doesn't work
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexpress/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/remyth/run2
3 files changed, 3 insertions, 3 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 68921e0..b9ec500 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=87
+pkgrel=88
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexpress/run b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
index d902721..db3eba1 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythexpress/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
@@ -5,5 +5,5 @@ export TERM=linux
. /etc/rc.d/functions
/sbin/svwaitup -s 10 /service/avahi
stat_runit "Starting MythExpress"
-su http -s/bin/bash -c "node /usr/mythexpress/app.js"
+exec su http -s/bin/bash -c "node /usr/mythexpress/app.js"
diff --git a/abs/core/runit-scripts/runitscripts/services/remyth/run b/abs/core/runit-scripts/runitscripts/services/remyth/run
index 599a8aa..768ec13 100755
--- a/abs/core/runit-scripts/runitscripts/services/remyth/run
+++ b/abs/core/runit-scripts/runitscripts/services/remyth/run
@@ -6,5 +6,5 @@ export TERM=linux
/sbin/svwaitup -s 10 /service/avahi
stat_runit "Starting ReMyth"
-su http -s/bin/bash -c "node /usr/remyth/server.js"
+exec su http -s/bin/bash -c "node /usr/remyth/server.js"