summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-09-21 20:13:59 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-09-21 20:13:59 (GMT)
commit133c9ea02b7b87ecd6f85cdf4be4f82870860648 (patch)
treedfaa5ee68ef3375ca0049bcae39517bbf3ed389c /abs/core/runit-scripts
parentad7da086568778579b2f81cedf7aa4690e220b6e (diff)
downloadlinhes_pkgbuild-133c9ea02b7b87ecd6f85cdf4be4f82870860648.zip
linhes_pkgbuild-133c9ea02b7b87ecd6f85cdf4be4f82870860648.tar.gz
linhes_pkgbuild-133c9ea02b7b87ecd6f85cdf4be4f82870860648.tar.bz2
runit-scripts: mythbackend run, mythexpress run, remyth run - don't use su in exec
At some point after su was updated runit can no longer manage process started with su and gives runsv not running errors when starting/stoping services. chpst is bundled with runit and is used as a replacement. However mythbackend gives tuner permissions errors when run with chpst on my systems. Using sudo to start mythbackend doesn't give the tuner errors and runit can manage the process. frontend alos uses su but I am not sure of a solution there.
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythbackend/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexpress/run3
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/remyth/run3
4 files changed, 4 insertions, 6 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 7cef4f0..d43e59f 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.2
-pkgrel=1
+pkgrel=2
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/mythbackend/run b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
index 8afd737..d97cf21 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythbackend/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
@@ -79,5 +79,5 @@ export HOME=/root
stat_runit "Starting Primary MythBackend"
fi
- exec su mythtv -c "/usr/bin/mythbackend -q --syslog local6"
+ exec sudo -u mythtv /usr/bin/mythbackend -q --syslog local6
# fi
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexpress/run b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
index 7410f43..06e4a1b 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythexpress/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythexpress/run
@@ -5,5 +5,4 @@ export TERM=linux
. /etc/rc.d/functions
/usr/bin/svwaitup -s 10 /service/avahi
stat_runit "Starting MythExpress"
-exec su http -s/bin/bash -c "node /usr/mythexpress/app.js"
-
+exec chpst -u http node /usr/mythexpress/app.js
diff --git a/abs/core/runit-scripts/runitscripts/services/remyth/run b/abs/core/runit-scripts/runitscripts/services/remyth/run
index 430d535..9667b87 100755
--- a/abs/core/runit-scripts/runitscripts/services/remyth/run
+++ b/abs/core/runit-scripts/runitscripts/services/remyth/run
@@ -6,5 +6,4 @@ export TERM=linux
/usr/bin/svwaitup -s 10 /service/avahi
stat_runit "Starting ReMyth"
-exec su http -s/bin/bash -c "node /usr/remyth/server.js"
-
+exec chpst -u http node /usr/remyth/app.js