summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2011-08-03 23:33:45 (GMT)
committerJames Meyer <james.meyer@operamail.com>2011-08-03 23:33:45 (GMT)
commit5003a9ce7a704794e298153fbaafccbfe534919f (patch)
tree65ae295b7bf5e9ec25f451fb16f4f7f9d781ca1c /abs/core/runit-scripts
parent02797173a65f18a0309e12699c7020eb015704cb (diff)
parent2ba0826ab4c85aa4caf1613cfdb77123935a16b4 (diff)
downloadlinhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.zip
linhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.tar.gz
linhes_pkgbuild-5003a9ce7a704794e298153fbaafccbfe534919f.tar.bz2
Merge branch 'testing' of ssh://jams@linhes.org/mount/repository/linhes_pkgbuild into testing
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/lighttpd/run7
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexport/finish4
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythexport/run10
4 files changed, 21 insertions, 2 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index f6cace4..e186f99 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=22
+pkgrel=24
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/lighttpd/run b/abs/core/runit-scripts/runitscripts/services/lighttpd/run
index 798690c..f9c574d 100755
--- a/abs/core/runit-scripts/runitscripts/services/lighttpd/run
+++ b/abs/core/runit-scripts/runitscripts/services/lighttpd/run
@@ -4,5 +4,10 @@ export TERM=linux
. /etc/rc.d/functions
stat_runit "Starting lighttpd"
+if [ ! -d /var/run/lighttpd ] ; then
+ mkdir -p /var/run/lighttpd
+ chown http /var/run/lighttpd
+fi
-exec /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
+# Using -angel to start lighttpd allows lighttpd to accept signals
+exec /usr/sbin/lighttpd-angel -D -f /etc/lighttpd/lighttpd.conf
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexport/finish b/abs/core/runit-scripts/runitscripts/services/mythexport/finish
new file mode 100755
index 0000000..b7fa7a6
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mythexport/finish
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+# runit only knows about the run script wrapper, so kill the daemon ourselves
+ kill `pidof -o %PPID -x /usr/bin/mythexport-daemon` >/dev/null 2>&1
diff --git a/abs/core/runit-scripts/runitscripts/services/mythexport/run b/abs/core/runit-scripts/runitscripts/services/mythexport/run
new file mode 100755
index 0000000..45f77fd
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mythexport/run
@@ -0,0 +1,10 @@
+#!/bin/bash
+
+/sbin/chpst -u mythtv /usr/bin/mythexport-daemon
+
+PID=`pidof -o %PPID -x /usr/bin/mythexport-daemon`
+
+# Wait until daemon dies, else runit can't supervise us
+ while [ "`pidof -o %PPID -x /usr/bin/mythexport-daemon`" == "$PID" ]; do
+ sleep 2
+ done