summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-09 23:55:10 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-09 23:55:10 (GMT)
commit53a9bfc6166ef4181ddc5797c6b3a0c441887585 (patch)
tree6e892d12b87a66dbb77856379bb0f9b97c3d6dc9 /abs/core/runit-scripts
parentcee8401afb62d7a8e4c115e28638e2f2d8c5893b (diff)
downloadlinhes_pkgbuild-53a9bfc6166ef4181ddc5797c6b3a0c441887585.zip
linhes_pkgbuild-53a9bfc6166ef4181ddc5797c6b3a0c441887585.tar.gz
linhes_pkgbuild-53a9bfc6166ef4181ddc5797c6b3a0c441887585.tar.bz2
runit-scripts: attempting to integrate plymouth a bit better. Mostly minor changes to levels 1 and 3
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/114
-rwxr-xr-xabs/core/runit-scripts/runitscripts/313
3 files changed, 17 insertions, 12 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 970f927..1fb818d 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=90
+pkgrel=91
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/1 b/abs/core/runit-scripts/runitscripts/1
index 0f1b8a9..0cb8307 100755
--- a/abs/core/runit-scripts/runitscripts/1
+++ b/abs/core/runit-scripts/runitscripts/1
@@ -2,7 +2,8 @@
/etc/rc.sysinit
. /etc/rc.conf
. /etc/rc.d/functions
-hostname `cat /etc/hostname`
+#no longer needed rc.sysinit takes care of the hostname
+#hostname `cat /etc/hostname`
/sbin/sysctl -p 2>/dev/null >/dev/null
#make sure permissions are right for /etc/systemconfig
chown root:mythtv /etc/systemconfig
@@ -12,7 +13,7 @@ chmod 774 /etc/systemconfig
#yes it's needed the 2nd time
/usr/LH/bin/load-modules-mythvantage.sh >/dev/null
rm /etc/dhcpc/dhcpcd*.pid 2>/dev/null
-rm -f /etc/sv/frontend/.runtime/* 2>/dev/null
+rm -f /service/frontend/.runtime/* 2>/dev/null
rm -f /etc/runit/reboot 2>/dev/null
/sbin/agetty -8 38400 tty10 linux &
stat_busy "Starting network"
@@ -30,4 +31,13 @@ then
/etc/runit/1.local
stat_done
fi
+#some stuff from rc.multi
+run_hook multi_start
+# Load sysctl config files
+/usr/lib/systemd/systemd-sysctl
+# Load additional binary formats
+mountpoint -q /proc/sys/fs/binfmt_misc || mount /proc/sys/fs/binfmt_misc &>/dev/null || mount -t binfmt_misc binfmt /proc/sys/fs/binfmt_misc
+/usr/lib/systemd/systemd-binfmt
+bootlogd_stop
+rm -f /run/nologin
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 15e4c5f..aadab51 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -1,18 +1,13 @@
#!/bin/sh
-
+clear
. /etc/rc.conf
. /etc/rc.d/functions
-
-echo "======================================================================"
for i in `seq 3`
do
- echo " " > /dev/tty1
+echo " " > /dev/tty1
done
-if [ -f /lib/splash/cache/daemon.pid ]
-then
- pid=`cat /lib/splash/cache/daemon.pid`
- kill -9 $pid 2>/dev/null
-fi
+echo "======================================================================"
+
export PREVLEVEL=3
#user added stuff for level 3 of runit