summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-12-27 16:58:21 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-12-27 16:58:37 (GMT)
commit912e7ca6626505c47c3c582efb74ff26bc418a37 (patch)
treea9b5d9779792c587c04019f1d959a57b31027189 /abs/core/runit-scripts
parent15d5058bbe99f3046f81206723b8a57a5e4305f9 (diff)
downloadlinhes_pkgbuild-912e7ca6626505c47c3c582efb74ff26bc418a37.zip
linhes_pkgbuild-912e7ca6626505c47c3c582efb74ff26bc418a37.tar.gz
linhes_pkgbuild-912e7ca6626505c47c3c582efb74ff26bc418a37.tar.bz2
runit-scrips , mv_ir: remove loading of lirc_serial by modules.mythvantage, the run script takes care of loading with the correct values.
Add more debugging to remotes log refs #950
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/remotes/run25
2 files changed, 19 insertions, 8 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 9857b4a..b1240ab 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=5
+pkgrel=6
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/remotes/run b/abs/core/runit-scripts/runitscripts/services/remotes/run
index 4040d7e..2363a3a 100755
--- a/abs/core/runit-scripts/runitscripts/services/remotes/run
+++ b/abs/core/runit-scripts/runitscripts/services/remotes/run
@@ -14,6 +14,10 @@ fi
echo "`date` --- run started" >> $LOG
+echo "====== lirc modules already loaded ==========" >> $LOG
+lsmod |grep lirc >> $LOG
+echo "====== lirc modules end =========" >> $LOG
+echo >> $LOG
#What is done in this file may not be enough to start your specific remote.
#If that is true of your remote place your remote startup commands in:
# /etc/runit/lirc.sh
@@ -47,29 +51,36 @@ else
if [ -n "$serial_port" ]
then
+ echo "Serial device setup: $serial_port" >>$LOG
#/dev/ttyS0 (COM1), port 0x3f8, irq 4
#/dev/ttyS1 (COM2), port 0x2f8, irq 3
#/dev/ttyS2 (COM3), port 0x3e8, irq 4
#/dev/ttyS3 (COM4), port 0x2e8, irq 3
-
+ printhl " Using serial device, loading module lirc_serial"
case $serial_port in
ttyS0)
- FLAGS="io=0x3f8 irq=4"
+ FLAGS="io=0x3f8 irq=4 debug=1 "
;;
ttyS1)
- FLAGS="io=0x2f8 irq=3"
+ FLAGS="io=0x2f8 irq=3 debug=1"
;;
ttyS2)
- FLAGS="io=0x3e8 irq=4"
+ FLAGS="io=0x3e8 irq=4 debug=1"
;;
ttyS3)
- FLAGS="io=0x2e8 irq=3"
+ FLAGS="io=0x2e8 irq=3 debug=1"
;;
esac
- /usr/bin/setserial /dev/$serial_port uart none
+
+ /usr/bin/setserial /dev/$serial_port uart none 2>&1 >> $LOG
sleep 0.5
- /sbin/modprobe lirc_serial $FLAGS
+ echo "/sbin/modprobe lirc_serial $FLAGS" 2>&1 >> $LOG
+ /sbin/modprobe lirc_serial $FLAGS 2>&1 >> $LOG
sleep 0.5
+ echo "====== dmesg output ============" >>$LOG
+ dmesg | tail -10 >> $LOG
+ echo "======= dmesg end ===========" >>$LOG
+
fi
if [ x$HostBlasterType = xCommandIR -o x$ReceiverType = xCommandIR ]