summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2015-01-17 18:50:11 (GMT)
committerBritney Fransen <brfransen@gmail.com>2015-01-17 18:50:11 (GMT)
commit914d62440fa51e294c8ea901fef7f0e3953da23a (patch)
treef78d37a7ed394c35d5ff9f9e39eae6420d7bea45 /abs/core/runit-scripts
parent2d171e860b503e0ee1381d966c09960f9eebc321 (diff)
downloadlinhes_pkgbuild-914d62440fa51e294c8ea901fef7f0e3953da23a.zip
linhes_pkgbuild-914d62440fa51e294c8ea901fef7f0e3953da23a.tar.gz
linhes_pkgbuild-914d62440fa51e294c8ea901fef7f0e3953da23a.tar.bz2
runit-scripts: handle bootlogd in 1 and improve plymouth in 3
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/16
-rwxr-xr-xabs/core/runit-scripts/runitscripts/36
3 files changed, 11 insertions, 3 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 097c704..35620e6 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.3
-pkgrel=1
+pkgrel=2
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/1 b/abs/core/runit-scripts/runitscripts/1
index 9f92530..05c3707 100755
--- a/abs/core/runit-scripts/runitscripts/1
+++ b/abs/core/runit-scripts/runitscripts/1
@@ -55,4 +55,10 @@ run_hook multi_start
mountpoint -q /proc/sys/fs/binfmt_misc || mount /proc/sys/fs/binfmt_misc &>/dev/null || mount -t binfmt_misc binfmt /proc/sys/fs/binfmt_misc
/usr/lib/systemd/systemd-binfmt
+# Stop bootlogd and clean up /var/log/boot
+bootlogd_stop
+sed -i -r -e 's/\^\[\[[0-9]?;?[0-9]?[0-9]?;?[0-9]?[0-9]?[ms]//g' \
+ -e 's/\^\[(\[1?[0-9]1|%)G//g' -e 's/\^\[\[0;1//g' \
+ -e 's/\^\[(\[?[0-9]{1,})G//g' /var/log/boot
+
rm -f /run/nologin
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index 062f2c6..2a9fb0d 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -13,6 +13,10 @@ if [ -e "$pidfile" ]; then
plypid=`cat "$pidfile"`
if [ -n "$plypid" ]; then
kill -s CONT "$plypid"
+ plymouthd --mode=shutdown --pid-file=/run/plymouthd
+ plymouth --show-splash
+ kill "$plypid"
+ add_omit_pids `cat /run/plymouthd`
fi
fi
@@ -42,6 +46,4 @@ ethtool -s eth0 wol g 2>/dev/null
ethtool -s eth1 wol g 2>/dev/null
ethtool -s eth2 wol g 2>/dev/null
-plymouth quit --retain-splash
-
/etc/rc.shutdown