summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-11-07 21:06:37 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-11-07 21:06:37 (GMT)
commit9d99e4612f58669a4b26e10b8a32d27b28eef210 (patch)
treea0ed5b371727c7e4497aeb1926e17ac7c81caca9 /abs/core/runit-scripts
parentffedb07e5b2e772ff86d9101b128942bbfb5452a (diff)
downloadlinhes_pkgbuild-9d99e4612f58669a4b26e10b8a32d27b28eef210.zip
linhes_pkgbuild-9d99e4612f58669a4b26e10b8a32d27b28eef210.tar.gz
linhes_pkgbuild-9d99e4612f58669a4b26e10b8a32d27b28eef210.tar.bz2
runit-scripts: if /service/mysql is present make the frontend wait on it for 2 seconds. This ensures that the database will be ready by the time the FE starts. This only affects Master backends that run the FE
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/run4
2 files changed, 5 insertions, 1 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 4086460..68921e0 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=86
+pkgrel=87
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/run b/abs/core/runit-scripts/runitscripts/services/frontend/run
index c1e2f2d..7fb1795 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/run
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/run
@@ -15,6 +15,10 @@ touch /var/log/fluxbox.log
chown mythtv:mythtv /var/log/fluxbox.log
stat_runit "Starting LinHES frontend"
+if [ -e /service/mysql ]
+then
+ svwaitup -s 2 /service/mysql
+fi
#echo "Starting LinHES frontend" >/dev/tty1
exec /bin/su - mythtv -l -c /usr/LH/bin/LinHES-start