summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-12-17 20:10:04 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-12-17 20:10:04 (GMT)
commita446b6d544450122051e13074f1d874e0d03c64c (patch)
tree46ef73392877f36e17f35c02e8ba6ab9d1c4a349 /abs/core/runit-scripts
parente026945f45ffdcea5072e645b762940e85506606 (diff)
downloadlinhes_pkgbuild-a446b6d544450122051e13074f1d874e0d03c64c.zip
linhes_pkgbuild-a446b6d544450122051e13074f1d874e0d03c64c.tar.gz
linhes_pkgbuild-a446b6d544450122051e13074f1d874e0d03c64c.tar.bz2
runit-scripts: removed ldm, adding udevil. Also added log_care to 1 so that it runs on startup.
This ensures that logs are cleaned up and rotated out of the way even if the system is offline when the cron job is supposed to run. refs #883
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/18
-rwxr-xr-xabs/core/runit-scripts/runitscripts/33
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/udevil/log/run8
-rw-r--r--abs/core/runit-scripts/runitscripts/services/udevil/run (renamed from abs/core/runit-scripts/runitscripts/services/ldm/run)4
5 files changed, 22 insertions, 3 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 870fe71..7750289 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=2.1.1
-pkgrel=92
+pkgrel=99
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/1 b/abs/core/runit-scripts/runitscripts/1
index 0cb8307..9463e60 100755
--- a/abs/core/runit-scripts/runitscripts/1
+++ b/abs/core/runit-scripts/runitscripts/1
@@ -23,6 +23,14 @@ stat_done
/usr/sbin/ethtool -s eth0 wol g 2>/dev/null
/usr/sbin/ethtool -s eth1 wol g 2>/dev/null
/usr/sbin/ethtool -s eth2 wol g 2>/dev/null
+#cleanup of log files
+if [ -f /etc/cron.daily/log_care ]
+then
+ stat_busy "Cleaning up old logs"
+ /etc/cron.daily/log_care 2>/dev/null >/dev/null &
+ stat_done
+fi
+
#user added stuff for level 1 of runit
if [ -e /etc/runit/1.local ]
then
diff --git a/abs/core/runit-scripts/runitscripts/3 b/abs/core/runit-scripts/runitscripts/3
index aadab51..1a4b384 100755
--- a/abs/core/runit-scripts/runitscripts/3
+++ b/abs/core/runit-scripts/runitscripts/3
@@ -18,5 +18,8 @@ then
/etc/runit/3.local
stat_done
fi
+/usr/sbin/ethtool -s eth0 wol g 2>/dev/null
+/usr/sbin/ethtool -s eth1 wol g 2>/dev/null
+/usr/sbin/ethtool -s eth2 wol g 2>/dev/null
/etc/rc.shutdown
diff --git a/abs/core/runit-scripts/runitscripts/services/udevil/log/run b/abs/core/runit-scripts/runitscripts/services/udevil/log/run
new file mode 100755
index 0000000..db4817f
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/udevil/log/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+exec 2>&1
+#export TERM=linux
+#. /etc/rc.conf
+#. /etc/rc.d/functions
+#stat_runit "Starting devmon logger"
+/usr/bin/logger -p info -t udevil
+
diff --git a/abs/core/runit-scripts/runitscripts/services/ldm/run b/abs/core/runit-scripts/runitscripts/services/udevil/run
index 83e05b5..46f922c 100644
--- a/abs/core/runit-scripts/runitscripts/services/ldm/run
+++ b/abs/core/runit-scripts/runitscripts/services/udevil/run
@@ -2,5 +2,5 @@
export TERM=linux
. /etc/rc.conf
. /etc/rc.d/functions
-stat_runit "starting ldm"
-exec /usr/bin/ldm -u 1000 -g 1000
+stat_runit "starting udevil"
+exec /usr/bin/devmon -g