summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-12-26 20:13:40 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-12-26 20:13:40 (GMT)
commitaf515b99f692bcf1f0af57aabe8f7c1a950b32c5 (patch)
treed2cbd0bd7a159adac8ebc749e6c76d005ad4a42e /abs/core/runit-scripts
parent45f667c9512475b4cb5c5290557dea854d056634 (diff)
parent816f6f419c662354f4224f8d82387fc27693b0fb (diff)
downloadlinhes_pkgbuild-af515b99f692bcf1f0af57aabe8f7c1a950b32c5.zip
linhes_pkgbuild-af515b99f692bcf1f0af57aabe8f7c1a950b32c5.tar.gz
linhes_pkgbuild-af515b99f692bcf1f0af57aabe8f7c1a950b32c5.tar.bz2
Merge branch 'testing'
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD14
-rw-r--r--[-rwxr-xr-x]abs/core/runit-scripts/fbsplash-runit.sh46
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/apcupsd/run8
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/cron/log/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/log/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mpd/log/run5
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mpd/run9
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/msg_daemon/run3
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/mythbackend/run9
-rwxr-xr-x[-rw-r--r--]abs/core/runit-scripts/runitscripts/services/udevil/run1
10 files changed, 59 insertions, 40 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index b652cba..9857b4a 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
-pkgver=8.0
-pkgrel=6
+pkgver=8.1
+pkgrel=5
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
replaces=()
backup=('etc/runit/1.local' 'etc/runit/3.local')
install=runit.install
-source=(fbsplash-runit.sh)
+source=('fbsplash-runit.sh')
arch=('i686' 'x86_64')
build() {
@@ -24,12 +24,14 @@ package() {
install -d $pkgdir/etc/sv
install -d $pkgdir/sbin
install -d $pkgdir/etc/rc.d/functions.d
-
- install -m0700 1 2 3 1.local 3.local ctrlaltdel $pkgdir/etc/runit
+
+ #this file contains the function runit-stat which is needed by the runit service scripts
install -m755 $srcdir/fbsplash-runit.sh $pkgdir/etc/rc.d/functions.d/fbsplash-runit.sh
+
+ install -m0700 1 2 3 1.local 3.local ctrlaltdel $pkgdir/etc/runit
install -m0755 reboot-runit halt-runit logger $pkgdir/sbin
rsync -a --exclude=.svn services/* $pkgdir/etc/sv
chmod -R 755 $pkgdir/etc/sv
chown -R root:root $pkgdir/etc/sv
}
-md5sums=('c79246677d5ffe687bcf6df1b9c2abc2')
+md5sums=('30b944b91aa1f57c5469c8bd210cb497')
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
index 87435ee..9fb9591 100755..100644
--- a/abs/core/runit-scripts/fbsplash-runit.sh
+++ b/abs/core/runit-scripts/fbsplash-runit.sh
@@ -5,33 +5,33 @@ printhlr() {
}
stat_runit(){
- printf ""
- printhlr "${C_MAIN}${1}${C_CLEAR} "
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
}
# splash stuff #
if [ -e /etc/conf.d/fbcondecor ]
then
- . /etc/conf.d/fbcondecor
- . /sbin/splash-functions.sh
-
- case $0 in /etc/runit/1 )
- # Prevent splash destruction
- CONSOLEFONT=""
- # Continue to use a splash daemon started in initcpio
- if /bin/mountpoint -q /run/.splash-cache; then
- /bin/mount --move /run/.splash-cache $spl_cachedir || return
- # Mount a tmpfs
- else
- ( splash_cache_prep ) || return
- fi
-
- splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
-
- ;; /etc/runit/3 )
- ( splash_cache_prep ) || return
-
- splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
- esac
+ . /etc/conf.d/fbcondecor
+ . /sbin/splash-functions.sh
+
+ case $0 in /etc/runit/1 )
+ # Prevent splash destruction
+ CONSOLEFONT=""
+ # Continue to use a splash daemon started in initcpio
+ if /bin/mountpoint -q /run/.splash-cache; then
+ /bin/mount --move /run/.splash-cache $spl_cachedir || return
+ # Mount a tmpfs
+ else
+ ( splash_cache_prep ) || return
+ fi
+
+ splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
+
+ ;; /etc/runit/3 )
+ ( splash_cache_prep ) || return
+
+ splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
+ esac
fi
diff --git a/abs/core/runit-scripts/runitscripts/services/apcupsd/run b/abs/core/runit-scripts/runitscripts/services/apcupsd/run
new file mode 100755
index 0000000..70bd9e0
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/apcupsd/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+exec 2>&1
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+stat_runit "Starting APC UPS Daemon"
+exec /usr/bin/apcupsd -b -f /etc/apcupsd/apcupsd.conf
diff --git a/abs/core/runit-scripts/runitscripts/services/cron/log/run b/abs/core/runit-scripts/runitscripts/services/cron/log/run
index 9dd37e3..785d6c7 100755
--- a/abs/core/runit-scripts/runitscripts/services/cron/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/cron/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t cron
+ /usr/bin/logger -t cron
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/log/run b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
index 801eaf2..bd431b2 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t frontend
+ /usr/bin/logger -t frontend
diff --git a/abs/core/runit-scripts/runitscripts/services/mpd/log/run b/abs/core/runit-scripts/runitscripts/services/mpd/log/run
new file mode 100755
index 0000000..bc856fe
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mpd/log/run
@@ -0,0 +1,5 @@
+#!/bin/sh
+exec 2>&1
+. /etc/systemconfig
+ /usr/bin/logger -t mpd
+
diff --git a/abs/core/runit-scripts/runitscripts/services/mpd/run b/abs/core/runit-scripts/runitscripts/services/mpd/run
new file mode 100755
index 0000000..c4bd347
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/mpd/run
@@ -0,0 +1,9 @@
+#!/bin/sh
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
+stat_runit "Starting mpd"
+
+
+exec 2>&1
+exec /usr/bin/mpd --no-daemon --stdout 2>&1
diff --git a/abs/core/runit-scripts/runitscripts/services/msg_daemon/run b/abs/core/runit-scripts/runitscripts/services/msg_daemon/run
index 76bb702..6f1b4b7 100755
--- a/abs/core/runit-scripts/runitscripts/services/msg_daemon/run
+++ b/abs/core/runit-scripts/runitscripts/services/msg_daemon/run
@@ -5,4 +5,5 @@ export TERM=linux
. /etc/rc.d/functions
. /etc/profile
stat_runit "Starting osd message daemon"
-DISPLAY=127.0.0.1:0 /usr/LH/bin/msg_daemon.py
+exec env DISPLAY=127.0.0.1:0 /usr/LH/bin/msg_daemon.py
+
diff --git a/abs/core/runit-scripts/runitscripts/services/mythbackend/run b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
index 903979c..e24fc3d 100755
--- a/abs/core/runit-scripts/runitscripts/services/mythbackend/run
+++ b/abs/core/runit-scripts/runitscripts/services/mythbackend/run
@@ -79,12 +79,5 @@ export HOME=/root
stat_runit "Starting Primary MythBackend"
fi
-
-
- if pacman -Q mythtv | grep -q 0.24
- then
- exec su mythtv -c "/usr/bin/mythbackend --logfile /var/log/mythtv/mythbackend.log"
- else
- exec su mythtv -c "/usr/bin/mythbackend -q --syslog local6"
- fi
+ exec su mythtv -c "/usr/bin/mythbackend -q --syslog local6"
# fi
diff --git a/abs/core/runit-scripts/runitscripts/services/udevil/run b/abs/core/runit-scripts/runitscripts/services/udevil/run
index 46f922c..35fc273 100644..100755
--- a/abs/core/runit-scripts/runitscripts/services/udevil/run
+++ b/abs/core/runit-scripts/runitscripts/services/udevil/run
@@ -1,5 +1,6 @@
#!/bin/sh
export TERM=linux
+2>&1
. /etc/rc.conf
. /etc/rc.d/functions
stat_runit "starting udevil"