summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2013-12-09 17:57:09 (GMT)
committerJames Meyer <james.meyer@operamail.com>2013-12-09 17:58:42 (GMT)
commitbbf857eb8190fce32a4191e61dd28b890a7ea059 (patch)
tree12adb85e321d5adfc4ca5b3c9ab75567275a15ae /abs/core/runit-scripts
parentfa1c09c45b64e180f8deb8c7d4858e1a2eb5fb01 (diff)
downloadlinhes_pkgbuild-bbf857eb8190fce32a4191e61dd28b890a7ea059.zip
linhes_pkgbuild-bbf857eb8190fce32a4191e61dd28b890a7ea059.tar.gz
linhes_pkgbuild-bbf857eb8190fce32a4191e61dd28b890a7ea059.tar.bz2
runit-scripts: fix cron and frontend logging to their own file
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD11
-rw-r--r--abs/core/runit-scripts/fbsplash-runit.sh37
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/cron/log/run2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/log/run2
4 files changed, 46 insertions, 6 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 745edb3..1f1c12c 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=2
+pkgrel=3
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
replaces=()
backup=('etc/runit/1.local' 'etc/runit/3.local')
install=runit.install
-source=()
+source=('fbsplash-runit.sh')
arch=('i686' 'x86_64')
build() {
@@ -24,11 +24,14 @@ package() {
install -d $pkgdir/etc/sv
install -d $pkgdir/sbin
install -d $pkgdir/etc/rc.d/functions.d
-
+
+ #this file contains the function runit-stat which is needed by the runit service scripts
+ install -m755 $srcdir/fbsplash-runit.sh $pkgdir/etc/rc.d/functions.d/fbsplash-runit.sh
+
install -m0700 1 2 3 1.local 3.local ctrlaltdel $pkgdir/etc/runit
install -m0755 reboot-runit halt-runit logger $pkgdir/sbin
rsync -a --exclude=.svn services/* $pkgdir/etc/sv
chmod -R 755 $pkgdir/etc/sv
chown -R root:root $pkgdir/etc/sv
}
-md5sums=()
+md5sums=('30b944b91aa1f57c5469c8bd210cb497')
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
new file mode 100644
index 0000000..9fb9591
--- /dev/null
+++ b/abs/core/runit-scripts/fbsplash-runit.sh
@@ -0,0 +1,37 @@
+# fbsplash functions.d runit script #
+
+printhlr() {
+ printf "${C_OTHER}${PREFIX_REG} ${C_H1}${1}${C_CLEAR} \n"
+ }
+
+stat_runit(){
+ printf ""
+ printhlr "${C_MAIN}${1}${C_CLEAR} "
+}
+
+
+# splash stuff #
+if [ -e /etc/conf.d/fbcondecor ]
+then
+ . /etc/conf.d/fbcondecor
+ . /sbin/splash-functions.sh
+
+ case $0 in /etc/runit/1 )
+ # Prevent splash destruction
+ CONSOLEFONT=""
+ # Continue to use a splash daemon started in initcpio
+ if /bin/mountpoint -q /run/.splash-cache; then
+ /bin/mount --move /run/.splash-cache $spl_cachedir || return
+ # Mount a tmpfs
+ else
+ ( splash_cache_prep ) || return
+ fi
+
+ splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
+
+ ;; /etc/runit/3 )
+ ( splash_cache_prep ) || return
+
+ splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
+ esac
+fi
diff --git a/abs/core/runit-scripts/runitscripts/services/cron/log/run b/abs/core/runit-scripts/runitscripts/services/cron/log/run
index 9dd37e3..785d6c7 100755
--- a/abs/core/runit-scripts/runitscripts/services/cron/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/cron/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t cron
+ /usr/bin/logger -t cron
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/log/run b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
index 801eaf2..bd431b2 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/log/run
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/log/run
@@ -1,5 +1,5 @@
#!/bin/sh
exec 2>&1
. /etc/systemconfig
- /usr/bin/logger -p local6.info -t frontend
+ /usr/bin/logger -t frontend