summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2014-04-06 22:43:48 (GMT)
committerBritney Fransen <brfransen@gmail.com>2014-04-06 22:43:48 (GMT)
commitd497ddcaf2064b008b39b291e4b1b1055ebde402 (patch)
tree54d12d4fc7050e8661348ad8a0720bef18eff70d /abs/core/runit-scripts
parent55bca972d1559f6874e8098297d7e1485068ef04 (diff)
downloadlinhes_pkgbuild-d497ddcaf2064b008b39b291e4b1b1055ebde402.zip
linhes_pkgbuild-d497ddcaf2064b008b39b291e4b1b1055ebde402.tar.gz
linhes_pkgbuild-d497ddcaf2064b008b39b291e4b1b1055ebde402.tar.bz2
runit-scripts: frontend finish: continue plymouthd. refs #891
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/frontend/finish20
2 files changed, 15 insertions, 7 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index ed76902..ea41c96 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=11
+pkgrel=12
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core/runit-scripts/runitscripts/services/frontend/finish b/abs/core/runit-scripts/runitscripts/services/frontend/finish
index 417488d..702b543 100755
--- a/abs/core/runit-scripts/runitscripts/services/frontend/finish
+++ b/abs/core/runit-scripts/runitscripts/services/frontend/finish
@@ -1,14 +1,23 @@
-#!/bin/bash
-exec 2>&1
-export TERM=linux
-. /etc/rc.conf
-. /etc/rc.d/functions
+#!/bin/bash
+exec 2>&1
+export TERM=linux
+. /etc/rc.conf
+. /etc/rc.d/functions
function cleanup(){
rm -f /etc/sv/frontend/.runtime/*
printhl " Cleaning up /etc/sv/frontend/.runtime/"
}
+#unpause plymouthd that was paused in /etc/X11/Sessions/Linhes
+pidfile=/run/plymouth.pid
+if [ -e "$pidfile" ]; then
+ plypid=`cat "$pidfile"`
+ if [ -n "$plypid" ]; then
+ kill -s CONT "$plypid"
+ fi
+fi
+
grep -q nox /proc/cmdline
STATUS=$?
if [ $STATUS = 0 ]
@@ -42,4 +51,3 @@ else
fi
fi
fi
-