summaryrefslogtreecommitdiffstats
path: root/abs/core/runit-scripts
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2013-12-04 20:25:28 (GMT)
committerBritney Fransen <brfransen@gmail.com>2013-12-04 20:25:28 (GMT)
commitdacae1d9673958dbeceae2ec93758cc3d4b9995e (patch)
treec563a7740326a95663ca3f0dc624108591e28cdb /abs/core/runit-scripts
parent1a88a6987070019e4901e7da132de64ff32d0694 (diff)
downloadlinhes_pkgbuild-dacae1d9673958dbeceae2ec93758cc3d4b9995e.zip
linhes_pkgbuild-dacae1d9673958dbeceae2ec93758cc3d4b9995e.tar.gz
linhes_pkgbuild-dacae1d9673958dbeceae2ec93758cc3d4b9995e.tar.bz2
apcupsd: readd for R8. closes#949.
runit-scripts: add apcupsd
Diffstat (limited to 'abs/core/runit-scripts')
-rwxr-xr-xabs/core/runit-scripts/PKGBUILD7
-rwxr-xr-xabs/core/runit-scripts/fbsplash-runit.sh37
-rwxr-xr-xabs/core/runit-scripts/runitscripts/services/apcupsd/run8
3 files changed, 11 insertions, 41 deletions
diff --git a/abs/core/runit-scripts/PKGBUILD b/abs/core/runit-scripts/PKGBUILD
index 2e5d50b..745edb3 100755
--- a/abs/core/runit-scripts/PKGBUILD
+++ b/abs/core/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=8.1
-pkgrel=1
+pkgrel=2
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
@@ -10,7 +10,7 @@ conflicts=()
replaces=()
backup=('etc/runit/1.local' 'etc/runit/3.local')
install=runit.install
-source=(fbsplash-runit.sh)
+source=()
arch=('i686' 'x86_64')
build() {
@@ -26,10 +26,9 @@ package() {
install -d $pkgdir/etc/rc.d/functions.d
install -m0700 1 2 3 1.local 3.local ctrlaltdel $pkgdir/etc/runit
- install -m755 $srcdir/fbsplash-runit.sh $pkgdir/etc/rc.d/functions.d/fbsplash-runit.sh
install -m0755 reboot-runit halt-runit logger $pkgdir/sbin
rsync -a --exclude=.svn services/* $pkgdir/etc/sv
chmod -R 755 $pkgdir/etc/sv
chown -R root:root $pkgdir/etc/sv
}
-md5sums=('c79246677d5ffe687bcf6df1b9c2abc2')
+md5sums=()
diff --git a/abs/core/runit-scripts/fbsplash-runit.sh b/abs/core/runit-scripts/fbsplash-runit.sh
deleted file mode 100755
index 87435ee..0000000
--- a/abs/core/runit-scripts/fbsplash-runit.sh
+++ /dev/null
@@ -1,37 +0,0 @@
-# fbsplash functions.d runit script #
-
-printhlr() {
- printf "${C_OTHER}${PREFIX_REG} ${C_H1}${1}${C_CLEAR} \n"
- }
-
-stat_runit(){
- printf ""
- printhlr "${C_MAIN}${1}${C_CLEAR} "
-}
-
-
-# splash stuff #
-if [ -e /etc/conf.d/fbcondecor ]
-then
- . /etc/conf.d/fbcondecor
- . /sbin/splash-functions.sh
-
- case $0 in /etc/runit/1 )
- # Prevent splash destruction
- CONSOLEFONT=""
- # Continue to use a splash daemon started in initcpio
- if /bin/mountpoint -q /run/.splash-cache; then
- /bin/mount --move /run/.splash-cache $spl_cachedir || return
- # Mount a tmpfs
- else
- ( splash_cache_prep ) || return
- fi
-
- splash_comm_send set message "$SPLASH_BOOT_MESSAGE"
-
- ;; /etc/runit/3 )
- ( splash_cache_prep ) || return
-
- splash_comm_send set message "$SPLASH_SHUTDOWN_MESSAGE"
- esac
-fi
diff --git a/abs/core/runit-scripts/runitscripts/services/apcupsd/run b/abs/core/runit-scripts/runitscripts/services/apcupsd/run
new file mode 100755
index 0000000..70bd9e0
--- /dev/null
+++ b/abs/core/runit-scripts/runitscripts/services/apcupsd/run
@@ -0,0 +1,8 @@
+#!/bin/sh
+exec 2>&1
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+stat_runit "Starting APC UPS Daemon"
+exec /usr/bin/apcupsd -b -f /etc/apcupsd/apcupsd.conf