summaryrefslogtreecommitdiffstats
path: root/abs/core/sdl
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2012-08-07 18:55:08 (GMT)
committerJames Meyer <james.meyer@operamail.com>2012-08-07 18:55:08 (GMT)
commited98b50bba7db4dd2f5aaf0d9302b3479372f616 (patch)
treea49fecf2379497d8bbcf2bdb72e6df1b2992c2bd /abs/core/sdl
parent5c17ecd1c2078925fc6034527b0ed13f155824d6 (diff)
downloadlinhes_pkgbuild-ed98b50bba7db4dd2f5aaf0d9302b3479372f616.zip
linhes_pkgbuild-ed98b50bba7db4dd2f5aaf0d9302b3479372f616.tar.gz
linhes_pkgbuild-ed98b50bba7db4dd2f5aaf0d9302b3479372f616.tar.bz2
sdl: 1.2.15
Diffstat (limited to 'abs/core/sdl')
-rw-r--r--abs/core/sdl/PKGBUILD24
-rw-r--r--abs/core/sdl/__changelog1
-rw-r--r--abs/core/sdl/sdl-1.2.14-disable-mmx.patch13
-rw-r--r--abs/core/sdl/sdl-1.2.14-fix-disappearing-cursor.patch17
-rw-r--r--abs/core/sdl/sdl-1.2.14-joystick-crash.diff14
5 files changed, 24 insertions, 45 deletions
diff --git a/abs/core/sdl/PKGBUILD b/abs/core/sdl/PKGBUILD
index 5f3bcc0..9e3b3e3 100644
--- a/abs/core/sdl/PKGBUILD
+++ b/abs/core/sdl/PKGBUILD
@@ -1,33 +1,31 @@
-# $Id: PKGBUILD 82982 2010-06-20 08:19:40Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id: PKGBUILD 147154 2012-01-23 14:30:05Z heftig $
+# Maintainer: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: dorphell <dorphell@archlinux.org>
pkgname=sdl
-pkgver=1.2.14
-pkgrel=6
+pkgver=1.2.15
+pkgrel=1
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
arch=('i686' 'x86_64')
url="http://www.libsdl.org"
license=('LGPL')
depends=('glibc' 'libxext' 'libxrender' 'libx11')
-makedepends=('alsa-lib' 'esound' 'mesa')
+makedepends=('alsa-lib' 'mesa' )
options=('!libtool')
source=(http://www.libsdl.org/release/SDL-${pkgver}.tar.gz
- sdl-1.2.14-joystick-crash.diff
sdl-1.2.14-fix-mouse-clicking.patch
- sdl-1.2.14-fix-disappearing-cursor.patch)
-md5sums=('e52086d1b508fa0b76c52ee30b55bec4'
- '9d8890b3817736a5d365f7497f096634'
+ sdl-1.2.14-disable-mmx.patch)
+md5sums=('9d96df8417572a2afb781a7c4c811a85'
'04d8c179f125e04bcd4c9d60e013c2d7'
- 'a6cf3e71b653aa97d0d8ae6c0a789807')
+ 'e5c16b7611f62c7cb25f0534eff68852')
build() {
cd ${srcdir}/SDL-${pkgver}
- patch -Np1 -i $srcdir/sdl-1.2.14-joystick-crash.diff
patch -Np1 -i $srcdir/sdl-1.2.14-fix-mouse-clicking.patch
- patch -Np1 -i $srcdir/sdl-1.2.14-fix-disappearing-cursor.patch
+ patch -Np1 -i $srcdir/sdl-1.2.14-disable-mmx.patch
./configure --prefix=/usr --disable-nasm --enable-alsa --disable-esd \
- --with-x --disable-rpath
+ --with-x --disable-rpath --disable-static
make
}
diff --git a/abs/core/sdl/__changelog b/abs/core/sdl/__changelog
deleted file mode 100644
index 7556af0..0000000
--- a/abs/core/sdl/__changelog
+++ /dev/null
@@ -1 +0,0 @@
-disable esd
diff --git a/abs/core/sdl/sdl-1.2.14-disable-mmx.patch b/abs/core/sdl/sdl-1.2.14-disable-mmx.patch
new file mode 100644
index 0000000..1bb6e0e
--- /dev/null
+++ b/abs/core/sdl/sdl-1.2.14-disable-mmx.patch
@@ -0,0 +1,13 @@
+# and another one from FS#26020
+
+--- a/src/video/SDL_yuv_sw.c 2009-10-13 06:07:15.000000000 +0700
++++ b/src/video/SDL_yuv_sw.c 2011-09-20 19:26:30.247742620 +0700
+@@ -89,6 +89,8 @@
+ #include "SDL_yuvfuncs.h"
+ #include "SDL_yuv_sw_c.h"
+
++#undef __OPTIMIZE__
++
+ /* The functions used to manipulate software video overlays */
+ static struct private_yuvhwfuncs sw_yuvfuncs = {
+ SDL_LockYUV_SW,
diff --git a/abs/core/sdl/sdl-1.2.14-fix-disappearing-cursor.patch b/abs/core/sdl/sdl-1.2.14-fix-disappearing-cursor.patch
deleted file mode 100644
index fcd3c31..0000000
--- a/abs/core/sdl/sdl-1.2.14-fix-disappearing-cursor.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Index: SDL-1.2.14/src/video/x11/SDL_x11events.c
-===================================================================
---- SDL-1.2.14.orig/src/video/x11/SDL_x11events.c 2010-04-30 09:16:35.000000000 -0400
-+++ SDL-1.2.14/src/video/x11/SDL_x11events.c 2010-04-30 09:16:35.000000000 -0400
-@@ -444,8 +444,10 @@
- if ( xevent.xcrossing.mode == NotifyUngrab )
- printf("Mode: NotifyUngrab\n");
- #endif
-- if ( xevent.xcrossing.detail != NotifyInferior ) {
-- if ( this->input_grab == SDL_GRAB_OFF ) {
-+ if ( (xevent.xcrossing.mode != NotifyGrab) &&
-+ (xevent.xcrossing.mode != NotifyUngrab) &&
-+ (xevent.xcrossing.detail != NotifyInferior) ) {
-+ if ( this->input_grab == SDL_GRAB_OFF ) {
- posted = SDL_PrivateAppActive(0, SDL_APPMOUSEFOCUS);
- } else {
- posted = SDL_PrivateMouseMotion(0, 0,
diff --git a/abs/core/sdl/sdl-1.2.14-joystick-crash.diff b/abs/core/sdl/sdl-1.2.14-joystick-crash.diff
deleted file mode 100644
index 949e18b..0000000
--- a/abs/core/sdl/sdl-1.2.14-joystick-crash.diff
+++ /dev/null
@@ -1,14 +0,0 @@
-Description: Fix crash with joystick detection.
-Index: libsdl1.2-1.2.14/src/joystick/linux/SDL_sysjoystick.c
-===================================================================
---- libsdl1.2-1.2.14.orig/src/joystick/linux/SDL_sysjoystick.c 2010-01-12 12:37:36.000000000 -0500
-+++ libsdl1.2-1.2.14/src/joystick/linux/SDL_sysjoystick.c 2010-01-12 12:38:27.000000000 -0500
-@@ -700,7 +700,7 @@
- continue;
- }
- if ( test_bit(i, absbit) ) {
-- int values[5];
-+ int values[6];
-
- if ( ioctl(fd, EVIOCGABS(i), values) < 0 )
- continue;