summaryrefslogtreecommitdiffstats
path: root/abs/core/sed
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-24 02:53:03 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-24 02:53:03 (GMT)
commiteffedab9cb3034ef67ed0bf9b4d2ef94e96a30aa (patch)
tree673caf6c4cd2cba01a1f99c20805e9154011e386 /abs/core/sed
parentf733b00c8c603d6d62706e5a4057ab774ad6f407 (diff)
downloadlinhes_pkgbuild-effedab9cb3034ef67ed0bf9b4d2ef94e96a30aa.zip
linhes_pkgbuild-effedab9cb3034ef67ed0bf9b4d2ef94e96a30aa.tar.gz
linhes_pkgbuild-effedab9cb3034ef67ed0bf9b4d2ef94e96a30aa.tar.bz2
sed: upgrade
Diffstat (limited to 'abs/core/sed')
-rw-r--r--abs/core/sed/PKGBUILD31
-rw-r--r--abs/core/sed/sed.install20
2 files changed, 39 insertions, 12 deletions
diff --git a/abs/core/sed/PKGBUILD b/abs/core/sed/PKGBUILD
index 787464b..a7063f5 100644
--- a/abs/core/sed/PKGBUILD
+++ b/abs/core/sed/PKGBUILD
@@ -1,21 +1,28 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 77816 2010-04-18 08:52:19Z allan $
+# Maintainer: Allan McRae <allan@archlinux.org>
+# Contributor: judd <jvinet@zeroflux.org>
+
pkgname=sed
-pkgver=4.1.5
-pkgrel=12
+pkgver=4.2.1
+pkgrel=2
pkgdesc="GNU stream editor"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://www.gnu.org/software/sed"
-license=('GPL')
+license=('GPL3')
groups=('base')
-depends=('glibc')
+depends=('acl' 'sh')
+makedepends=('gettext')
+install=sed.install
source=(ftp://ftp.gnu.org/pub/gnu/sed/$pkgname-$pkgver.tar.gz)
-md5sums=('7a1cbbbb3341287308e140bd4834c3ba')
+md5sums=('f0fd4d7da574d4707e442285fd2d3b86')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --bindir=/bin --without-included-regex
make || return 1
- make prefix=$startdir/pkg/usr install
- mv $startdir/pkg/usr/bin $startdir/pkg/
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
}
diff --git a/abs/core/sed/sed.install b/abs/core/sed/sed.install
new file mode 100644
index 0000000..c052403
--- /dev/null
+++ b/abs/core/sed/sed.install
@@ -0,0 +1,20 @@
+infodir=/usr/share/info
+filelist=(sed.info)
+
+post_install() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ for file in ${filelist[@]}; do
+ install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
+ done
+}