summaryrefslogtreecommitdiffstats
path: root/abs/core/shadow/PKGBUILD
diff options
context:
space:
mode:
authorJames Meyer <james.meyer@operamail.com>2014-02-17 00:00:01 (GMT)
committerJames Meyer <james.meyer@operamail.com>2014-02-19 19:03:04 (GMT)
commit0b5bffbcb70ad84d0ff3ce8bac958a752d80807e (patch)
treeb84b6c0ac59403ff06f5f53995c7d4d52816da82 /abs/core/shadow/PKGBUILD
parent2c68a40cdbfe2392ada429d1e126e551323ab10e (diff)
downloadlinhes_pkgbuild-0b5bffbcb70ad84d0ff3ce8bac958a752d80807e.zip
linhes_pkgbuild-0b5bffbcb70ad84d0ff3ce8bac958a752d80807e.tar.gz
linhes_pkgbuild-0b5bffbcb70ad84d0ff3ce8bac958a752d80807e.tar.bz2
shadow:
update binary path to /usr/bin refs #961
Diffstat (limited to 'abs/core/shadow/PKGBUILD')
-rw-r--r--abs/core/shadow/PKGBUILD57
1 files changed, 34 insertions, 23 deletions
diff --git a/abs/core/shadow/PKGBUILD b/abs/core/shadow/PKGBUILD
index 971b59a..0ca6f54 100644
--- a/abs/core/shadow/PKGBUILD
+++ b/abs/core/shadow/PKGBUILD
@@ -1,10 +1,10 @@
-# $Id: PKGBUILD 162993 2012-07-04 21:45:24Z dreisner $
+# $Id: PKGBUILD 197840 2013-10-30 11:06:53Z allan $
# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Aaron Griffin <aaron@archlinux.org>
pkgname=shadow
pkgver=4.1.5.1
-pkgrel=1
+pkgrel=7
pkgdesc="Password and account management tool suite with support for shadow files and PAM"
arch=('i686' 'x86_64')
url='http://pkg-shadow.alioth.debian.org/'
@@ -16,11 +16,10 @@ backup=(etc/login.defs
etc/pam.d/{chpasswd,newusers,groupadd,groupdel,groupmod}
etc/pam.d/{chgpasswd,groupmems}
etc/default/useradd)
-options=('!libtool')
+options=(strip debug)
install='shadow.install'
source=("http://pkg-shadow.alioth.debian.org/releases/$pkgname-$pkgver.tar.bz2"{,.sig}
LICENSE
- adduser
chgpasswd
chpasswd
defaults.pam
@@ -30,21 +29,22 @@ source=("http://pkg-shadow.alioth.debian.org/releases/$pkgname-$pkgver.tar.bz2"{
shadow.cron.daily
useradd.defaults
xstrdup.patch
- shadow-strncpy-usage.patch)
+ shadow-strncpy-usage.patch
+ lastlog.tmpfiles)
sha1sums=('81f38720b953ef9c2c100c43d02dfe19cafd6c30'
- '126570e2939bf3b57f28df5197ab9309747a6b5c'
+ 'SKIP'
'33a6cf1e44a1410e5c9726c89e5de68b78f5f922'
- '78ec184a499f9708adcfcf0b7a3b22a60bf39f91'
'4ad0e059406a305c8640ed30d93c2a1f62c2f4ad'
'12427b1ca92a9b85ca8202239f0d9f50198b818f'
'0e56fed7fc93572c6bf0d8f3b099166558bb46f1'
- 'e5cab2118ecb1e61874cde842d7d04d1003f35cb'
+ 'e92045fb75e0c21a3f294a00de0bd2cd252e9463'
'12427b1ca92a9b85ca8202239f0d9f50198b818f'
'611be25d91c3f8f307c7fe2485d5f781e5dee75f'
- '5d83ba7e11c765c951867cbe00b0ae7ff57148fa'
+ '98f4919014b1a9eb9f01ca7731e04b1d973cedd5'
'9ae93de5987dd0ae428f0cc1a5a5a5cd53583f19'
'6010fffeed1fc6673ad9875492e1193b1a847b53'
- '21e12966a6befb25ec123b403cd9b5c492fe5b16')
+ '21e12966a6befb25ec123b403cd9b5c492fe5b16'
+ 'f57ecde3f72b4738fad75c097d19cf46a412350f')
build() {
cd "$pkgname-$pkgver"
@@ -53,7 +53,7 @@ build() {
sed -i '/^user\(mod\|add\)_LDADD/s|$| -lattr|' src/Makefile.am
# link to glibc's crypt(3)
- LDFLAGS+=" -lcrypt"
+ export LIBS="-lcrypt"
# need to offer these upstream
patch -Np1 <"$srcdir/xstrdup.patch"
@@ -64,11 +64,14 @@ build() {
./configure \
--prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/bin \
--libdir=/lib \
--mandir=/usr/share/man \
--sysconfdir=/etc \
--with-libpam \
- --without-selinux
+ --without-selinux \
+ --with-group-name-max-length=32
make
}
@@ -81,9 +84,6 @@ package() {
# license
install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/shadow/LICENSE"
- # interactive useradd
- install -Dm755 "$srcdir/adduser" "$pkgdir/usr/sbin/adduser"
-
# useradd defaults
install -Dm644 "$srcdir/useradd.defaults" "$pkgdir/etc/default/useradd"
@@ -106,10 +106,15 @@ package() {
install -Dm644 "$srcdir/defaults.pam" "$pkgdir/etc/pam.d/$file"
done
+ # lastlog log file creation
+ install -Dm644 "$srcdir/lastlog.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/lastlog.conf"
+
+ # Remove evil/broken tools
+ rm "$pkgdir"/usr/sbin/logoutd
+
# Remove utilities provided by util-linux
rm \
- "$pkgdir"/usr/bin/{chsh,chfn,sg} \
- "$pkgdir"/bin/{login,su} \
+ "$pkgdir"/usr/bin/{login,su,chsh,chfn,sg,nologin} \
"$pkgdir"/usr/sbin/{vipw,vigr}
# but we keep newgrp, as sg is really an alias to it
@@ -117,15 +122,21 @@ package() {
# ...and their many man pages
find "$pkgdir"/usr/share/man \
- '(' -name 'chsh.1' -o \
- -name 'chfn.1' -o \
- -name 'su.1' -o \
- -name 'login.1' -o \
- -name 'vipw.8' -o \
- -name 'vigr.8' -o \
+ '(' -name 'chsh.1' -o \
+ -name 'chfn.1' -o \
+ -name 'su.1' -o \
+ -name 'logoutd.8' -o \
+ -name 'login.1' -o \
+ -name 'nologin.8' -o \
+ -name 'vipw.8' -o \
+ -name 'vigr.8' -o \
-name 'newgrp.1' ')' \
-delete
rmdir \
"$pkgdir"/usr/share/man/{fi,id,zh_TW}/man1 \
"$pkgdir"/usr/share/man/{fi,ko/man8}
+
+ # move everything else to /usr/bin, because this isn't handled by ./configure
+ mv "$pkgdir"/usr/sbin/* "$pkgdir"/usr/bin
+ rmdir "$pkgdir/usr/sbin"
}