summaryrefslogtreecommitdiffstats
path: root/abs/core/squashfs-tools
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2016-01-28 01:33:34 (GMT)
committerBritney Fransen <brfransen@gmail.com>2016-01-28 01:33:34 (GMT)
commit3d024890c7b81120983efaf9a5cb2f02e8d502a8 (patch)
tree4b0799dcde1d415e960ac6cc5e821dd3635530f8 /abs/core/squashfs-tools
parent2d19ae949aa7e343e1983d44e52023079fb87f3f (diff)
downloadlinhes_pkgbuild-3d024890c7b81120983efaf9a5cb2f02e8d502a8.zip
linhes_pkgbuild-3d024890c7b81120983efaf9a5cb2f02e8d502a8.tar.gz
linhes_pkgbuild-3d024890c7b81120983efaf9a5cb2f02e8d502a8.tar.bz2
squashfs-tools: update to 4.3-4
Diffstat (limited to 'abs/core/squashfs-tools')
-rw-r--r--abs/core/squashfs-tools/PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/abs/core/squashfs-tools/PKGBUILD b/abs/core/squashfs-tools/PKGBUILD
index 53db5b2..333d7ac 100644
--- a/abs/core/squashfs-tools/PKGBUILD
+++ b/abs/core/squashfs-tools/PKGBUILD
@@ -1,22 +1,23 @@
-# $Id: PKGBUILD 91959 2013-05-30 09:44:39Z spupykin $
+# $Id$
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Original TU: Jeff Mickey <j@codemac.net>
# Contributor: ciccio.a
pkgname=squashfs-tools
-pkgver=4.2
+pkgver=4.3
pkgrel=4
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
license=("GPL")
arch=('i686' 'x86_64')
-depends=('zlib' 'lzo2' 'xz')
+depends=('zlib' 'lzo' 'xz' 'lz4')
source=("http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz")
+md5sums=('d92ab59aabf5173f2a59089531e30dbf')
build() {
cd ${srcdir}/squashfs${pkgver}/${pkgname}
- make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1
+ make XZ_SUPPORT=1 LZO_SUPPORT=1 LZMA_XZ_SUPPORT=1 LZ4_SUPPORT=1
}
package() {
@@ -24,4 +25,3 @@ package() {
install -Dm755 mksquashfs ${pkgdir}/usr/bin/mksquashfs
install -m755 unsquashfs ${pkgdir}/usr/bin/unsquashfs
}
-md5sums=('1b7a781fb4cf8938842279bd3e8ee852')