summaryrefslogtreecommitdiffstats
path: root/abs/core/squashfs-tools
diff options
context:
space:
mode:
authorMichael Hanson <hansonorders@verizon.net>2010-11-30 01:47:23 (GMT)
committerMichael Hanson <hansonorders@verizon.net>2010-11-30 01:47:23 (GMT)
commit737ebffff1aded23113091ff023500e29a5337b0 (patch)
tree481606a39bab468c0fbba2bab3f1bf45a1ee38bf /abs/core/squashfs-tools
parent51a857a3f70bbb2ed2e60c0c743620779bbf12e1 (diff)
downloadlinhes_pkgbuild-737ebffff1aded23113091ff023500e29a5337b0.zip
linhes_pkgbuild-737ebffff1aded23113091ff023500e29a5337b0.tar.gz
linhes_pkgbuild-737ebffff1aded23113091ff023500e29a5337b0.tar.bz2
squashfs-tools: upgrade
Diffstat (limited to 'abs/core/squashfs-tools')
-rw-r--r--abs/core/squashfs-tools/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/abs/core/squashfs-tools/PKGBUILD b/abs/core/squashfs-tools/PKGBUILD
index fb99564..87a60db 100644
--- a/abs/core/squashfs-tools/PKGBUILD
+++ b/abs/core/squashfs-tools/PKGBUILD
@@ -1,25 +1,28 @@
-# $Id: PKGBUILD 70339 2010-02-26 03:50:39Z dgriffiths $
+# $Id: PKGBUILD 96914 2010-10-25 15:28:14Z pierre $
# Maintainer: Aaron Griffin <aaron@archlinux.org>
# Original TU: Jeff Mickey <j@codemac.net>
# Contributor: ciccio.a
pkgname=squashfs-tools
-pkgver=4.0
-pkgrel=3
+pkgver=4.1
+pkgrel=2
pkgdesc="Tools for squashfs, a highly compressed read-only filesystem for Linux."
url="http://squashfs.sourceforge.net"
license=("GPL")
arch=('i686' 'x86_64')
-depends=('zlib' 'glibc')
-source=(http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz mksquashfs-fix-race.patch)
+depends=('zlib' 'glibc' 'lzo2' 'xz')
+source=("http://downloads.sourceforge.net/sourceforge/squashfs/squashfs${pkgver}.tar.gz")
+md5sums=('8e1b2b96f5d5f3fe48fef226ae8cd341')
-build()
-{
+build() {
cd ${srcdir}/squashfs${pkgver}/${pkgname}
- patch < ${srcdir}/mksquashfs-fix-race.patch || return 1
+ sed -i 's|^#XZ_SUPPORT = 1|XZ_SUPPORT = 1|' Makefile
+ sed -i 's|^#LZO_SUPPORT = 1|LZO_SUPPORT = 1|' Makefile
make || return 1
- install -Dm755 mksquashfs ${pkgdir}/sbin/mksquashfs || return 1
- install -m755 unsquashfs ${pkgdir}/sbin/unsquashfs || return 1
}
-md5sums=('a3c23391da4ebab0ac4a75021ddabf96'
- '116b8a285ff8d61d59c48eb80c0ff564')
+
+package() {
+ cd ${srcdir}/squashfs${pkgver}/${pkgname}
+ install -Dm755 mksquashfs ${pkgdir}/sbin/mksquashfs
+ install -m755 unsquashfs ${pkgdir}/sbin/unsquashfs
+}