summaryrefslogtreecommitdiffstats
path: root/abs/core/sudo/PKGBUILD
diff options
context:
space:
mode:
authorBritney Fransen <brfransen@gmail.com>2018-03-01 16:01:01 (GMT)
committerBritney Fransen <brfransen@gmail.com>2018-03-01 16:01:01 (GMT)
commit8875dbe9faa67ed8cb8d8d470810f09c6013349e (patch)
treebe5ef4613d443190f791620e42c94cb2d98dc43f /abs/core/sudo/PKGBUILD
parent7d8c4bfc2f3d4c38af9e90cca0d089745af58b4d (diff)
downloadlinhes_pkgbuild-8875dbe9faa67ed8cb8d8d470810f09c6013349e.zip
linhes_pkgbuild-8875dbe9faa67ed8cb8d8d470810f09c6013349e.tar.gz
linhes_pkgbuild-8875dbe9faa67ed8cb8d8d470810f09c6013349e.tar.bz2
sudo: update to 1.8.22
Diffstat (limited to 'abs/core/sudo/PKGBUILD')
-rw-r--r--abs/core/sudo/PKGBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/abs/core/sudo/PKGBUILD b/abs/core/sudo/PKGBUILD
index 14f21ec..cf0753b 100644
--- a/abs/core/sudo/PKGBUILD
+++ b/abs/core/sudo/PKGBUILD
@@ -4,23 +4,27 @@
# Contributor: Tom Newsom <Jeepster@gmx.co.uk>
pkgname=sudo
-_sudover=1.8.14p3
+_sudover=1.8.22
pkgver=${_sudover/p/.p}
-pkgrel=2
+pkgrel=1
pkgdesc="Give certain users the ability to run some commands as root"
-arch=('i686' 'x86_64')
-url="http://www.sudo.ws/sudo/"
+arch=('x86_64')
+url="https://www.sudo.ws/sudo/"
license=('custom')
groups=('base-devel')
-depends=('glibc' 'pam' 'libldap')
+depends=('glibc' 'libgcrypt' 'pam' 'libldap')
backup=('etc/sudoers' 'etc/pam.d/sudo')
install=$pkgname.install
-source=(http://www.sudo.ws/sudo/dist/$pkgname-$_sudover.tar.gz{,.sig}
+source=(https://www.sudo.ws/sudo/dist/$pkgname-$_sudover.tar.gz{,.sig}
sudo.pam)
-sha256sums=('a8a697cbb113859058944850d098464618254804cf97961dee926429f00a1237'
+sha256sums=('7256cb27c20883b14360eddbd17f98922073d104b214cf65aeacf1d9c9b9fd02'
'SKIP'
'd1738818070684a5d2c9b26224906aad69a4fea77aabd960fc2675aee2df1fa2')
-validpgpkeys=('CCB24BE9E9481B15D34159535A89DFA27EE470C4')
+validpgpkeys=('59D1E9CCBA2B376704FDD35BA9F4C021CEA470FB')
+
+prepare() {
+ cd "$srcdir/$pkgname-$_sudover"
+}
build() {
cd "$srcdir/$pkgname-$_sudover"
@@ -32,6 +36,7 @@ build() {
--with-rundir=/run/sudo \
--with-vardir=/var/db/sudo \
--with-logfac=auth \
+ --enable-gcrypt \
--enable-tmpfiles.d \
--with-pam \
--with-sssd \
@@ -52,7 +57,10 @@ package() {
cd "$srcdir/$pkgname-$_sudover"
make DESTDIR="$pkgdir" install
- # Remove /run/sudo directory from the package; we create it using tmpfiles.d
+ # Remove sudoers.dist; not needed since pacman manages updates to sudoers
+ rm "$pkgdir/etc/sudoers.dist"
+
+ # Remove /run/sudo directory; we create it using systemd-tmpfiles
rmdir "$pkgdir/run/sudo"
rmdir "$pkgdir/run"